summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-13 21:14:39 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-13 21:15:09 +0200
commitb94633df167641dea74c92ebca18e6b7215e7a50 (patch)
tree5941d3dc2abb834494fde2a9f965e4f57fbac7e0 /sys-apps/hwloc
parentdev-db/cockroach: fix dependencies for #618338. (diff)
downloadgentoo-b94633df167641dea74c92ebca18e6b7215e7a50.tar.gz
gentoo-b94633df167641dea74c92ebca18e6b7215e7a50.tar.bz2
gentoo-b94633df167641dea74c92ebca18e6b7215e7a50.zip
sys-apps/hwloc: Port to EAPI 6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/hwloc-1.11.7.ebuild48
1 files changed, 24 insertions, 24 deletions
diff --git a/sys-apps/hwloc/hwloc-1.11.7.ebuild b/sys-apps/hwloc/hwloc-1.11.7.ebuild
index fbff0ec3ca19..0630d0411f9f 100644
--- a/sys-apps/hwloc/hwloc-1.11.7.ebuild
+++ b/sys-apps/hwloc/hwloc-1.11.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit flag-o-matic cuda autotools-multilib multilib versionator
+inherit autotools cuda flag-o-matic versionator multilib-minimal
MY_PV=v$(get_version_component_range 1-2)
@@ -35,36 +35,36 @@ RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
DEPEND="${RDEPEND}
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
DOCS=( AUTHORS NEWS README VERSION )
-PATCHES=(
- "${FILESDIR}/${PN}-1.8.1-gl.patch"
-)
-AUTOTOOLS_AUTORECONF=1
-
src_prepare() {
+ default
+ eautoreconf
+
if use cuda ; then
- append-cflags -I/opt/cuda/include
- append-cppflags -I/opt/cuda/include
+ append-cflags -I"${EPREFIX}"/opt/cuda/include
+ append-cppflags -I"${EPREFIX}"/opt/cuda/include
fi
- autotools-utils_src_prepare
}
multilib_src_configure() {
export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
- use cuda && local LDFLAGS="${LDFLAGS} -L/opt/cuda/$(get_libdir)"
- local myeconfargs=(
- --disable-silent-rules
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- $(use_enable cairo)
- $(use_enable cuda)
- $(use_enable debug)
- $(multilib_native_use_enable gl)
- $(use_enable pci)
- $(use_enable plugins)
- $(use_enable numa libnuma)
- $(use_enable xml libxml2)
+
+ if use cuda ; then
+ local -x LDFLAGS="${LDFLAGS}"
+ append-ldflags -L"${EPREFIX}"/opt/cuda/$(get_libdir)
+ fi
+
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static) \
+ $(use_enable cairo) \
+ $(use_enable cuda) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable gl) \
+ $(use_enable pci) \
+ $(use_enable plugins) \
+ $(use_enable numa libnuma) \
+ $(use_enable xml libxml2) \
$(use_with X x)
- )
- autotools-utils_src_configure
}