summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/intel-performance-counter-monitor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/intel-performance-counter-monitor')
-rw-r--r--sys-apps/intel-performance-counter-monitor/Manifest1
-rw-r--r--sys-apps/intel-performance-counter-monitor/intel-performance-counter-monitor-2.8.ebuild50
-rw-r--r--sys-apps/intel-performance-counter-monitor/metadata.xml10
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/intel-performance-counter-monitor/Manifest b/sys-apps/intel-performance-counter-monitor/Manifest
new file mode 100644
index 000000000000..fd3bb760cf56
--- /dev/null
+++ b/sys-apps/intel-performance-counter-monitor/Manifest
@@ -0,0 +1 @@
+DIST IntelPerformanceCounterMonitorV2.8.zip 931374 SHA256 3c51b2fc7b772f16f746ea6fda0471d280c0f27bfd52fa51dd78433ca5a6ca6a SHA512 7dbba8c051663a315dcf79224502d76cb4217a483a4b322f0be938e06b988e290a83b345cb8c60645aceb8283555067c2db529179782432ff77fddd538ef8b8f WHIRLPOOL 159015a5d37c7f64813a31892b615443471571e3d3bdf2d23cc4fba08819142bd4d7bf7565a9e15618ae6825f4c97cb630bb49aeb7bfbf1e5819960b99911905
diff --git a/sys-apps/intel-performance-counter-monitor/intel-performance-counter-monitor-2.8.ebuild b/sys-apps/intel-performance-counter-monitor/intel-performance-counter-monitor-2.8.ebuild
new file mode 100644
index 000000000000..918d13196ffb
--- /dev/null
+++ b/sys-apps/intel-performance-counter-monitor/intel-performance-counter-monitor-2.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator fcaps
+
+MY_PN="IntelPerformanceCounterMonitor"
+MY_PV="V2.8"
+MY_P="${MY_PN}${MY_PV}.zip"
+
+DESCRIPTION="Intel Performance Counter Monitor - A better way to measure CPU utilization"
+HOMEPAGE="https://software.intel.com/en-us/articles/intel-performance-counter-monitor-a-better-way-to-measure-cpu-utilization"
+SRC_URI="http://dev.gentoo.org/~dlan/distfiles/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=sys-devel/gcc-4:*"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+CONFIG_CHECK="~X86_MSR ~PERF_EVENTS"
+ERROR_X86_MSR="Intel Performance Counter Monitor, requires X86_MSR to be set in kernel config."
+
+S="${WORKDIR}/IntelPerformanceCounterMonitor${MY_PV}"
+
+src_prepare() {
+ sed -i 's/^#CXXFLAGS += -DPCM_USE_PERF/CXXFLAGS += -DPCM_USE_PERF/' Makefile || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe pcm.x pcm
+ newexe pcm-memory.x pcm-memory
+ newexe pcm-msr.x pcm-msr
+ newexe pcm-numa.x pcm-numa
+ newexe pcm-pcie.x pcm-pcie
+ newexe pcm-power.x pcm-power
+ newexe pcm-sensor.x pcm-sensor
+ newexe pcm-tsx.x pcm-tsx
+}
+
+pkg_postinst() {
+ fcaps CAP_SYS_RAWIO usr/bin/pcm
+ fcaps CAP_SYS_RAWIO usr/bin/pcm-{memory,msr,numa,pcie,power,tsx}
+}
diff --git a/sys-apps/intel-performance-counter-monitor/metadata.xml b/sys-apps/intel-performance-counter-monitor/metadata.xml
new file mode 100644
index 000000000000..c63b19ffc98e
--- /dev/null
+++ b/sys-apps/intel-performance-counter-monitor/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan 'undersys' Horan</name>
+ <description>Primary Maintainer, Assign bugs to him</description>
+ </maintainer>
+</pkgmetadata>