summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 02:16:02 +0100
committerSam James <sam@gentoo.org>2022-06-03 02:31:57 +0100
commit1fe6b8b959464c36e1251490c21f82c05ba2e76a (patch)
tree2463e178eaca762a00f5c517ec57b0c3eae4d102 /sys-apps/kbd
parentsys-apps/kbd: rephrase comment (diff)
downloadgentoo-1fe6b8b959464c36e1251490c21f82c05ba2e76a.tar.gz
gentoo-1fe6b8b959464c36e1251490c21f82c05ba2e76a.tar.bz2
gentoo-1fe6b8b959464c36e1251490c21f82c05ba2e76a.zip
sys-apps/kbd: add 2.5.0
Bug: https://bugs.gentoo.org/732868 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.5.0.ebuild100
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild44
3 files changed, 131 insertions, 14 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 3db59f47a2c2..01c0afbdec91 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1 +1,2 @@
DIST kbd-2.4.0.tar.xz 1120700 BLAKE2B aa5fc1067d3414b9fa18f35dd81dcc050cdf10bd8692221b6e5304e94c4f90055386ce1f79d2bd092241f9ce15ffd36d5c00d1a15725166d16183f475be4a2e3 SHA512 c3823e40878ed4cb5b90edf753dba37a7fc3189b7b08a2e59a7830cac23a7a7daf31dedef1fcc130698c7508bc2a037c8ab54e749d0cdbf51756e346f2ed5abb
+DIST kbd-2.5.0.tar.xz 1490112 BLAKE2B c123982d5c80fa3996f6328d7151a9dcc8c969e7beeb65e83204857b044355a3531dd1efe5634d844bc43f8d5715ec63e41120679a3d34888766ef7bf6014f2b SHA512 740c4c7b8a2729f5d0539399f691d4201dab97c6eec554b82cc8c80935e956072e9735a739f8f4febc9849c1e8d9d195318b1d0d4e10dce4d34b5fb6d84111d7
diff --git a/sys-apps/kbd/kbd-2.5.0.ebuild b/sys-apps/kbd/kbd-2.5.0.ebuild
new file mode 100644
index 000000000000..d0f3a2573fa7
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.5.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="https://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+RESTRICT="!test? ( test )"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+RDEPEND="
+ app-arch/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
+ cd "${S}"/data/keymaps/i386 || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # USE="test" installs .a files
+ --disable-static
+ --disable-werror
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Cheesy hack for now for https://github.com/legionus/kbd/issues/76
+ mv "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map "${S}"/data/keymaps/i386/qwerty/cz.map || die
+
+ default
+
+ mv "${S}"/data/keymaps/i386/qwerty/cz.map "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map || die
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc docs/doc/*.html
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index b430d89f0657..d0f3a2573fa7 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
- #EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
- EGIT_REPO_URI="https://github.com/legionus/kbd.git"
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
EGIT_BRANCH="master"
else
if [[ $(ver_cut 3) -lt 90 ]] ; then
SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
else
inherit autotools
SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -19,14 +18,17 @@ else
fi
DESCRIPTION="Keyboard and console utilities"
-HOMEPAGE="http://kbd-project.org/"
+HOMEPAGE="https://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
-#RESTRICT="!test? ( test )"
-# Upstream has strange assumptions how to run tests (see bug #732868)
-RESTRICT="test"
+RESTRICT="!test? ( test )"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
RDEPEND="
app-arch/gzip
@@ -42,23 +44,25 @@ BDEPEND="
"
src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
else
default
fi
+}
+
+src_prepare() {
+ default
# Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
cd "${S}"/data/keymaps/i386 || die
mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
mv olpc/es.map olpc/es-olpc.map || die
mv olpc/pt.map olpc/pt-olpc.map || die
mv qwerty/cz.map qwerty/cz-qwerty.map || die
-}
-src_prepare() {
- default
- if [[ ${PV} == "9999" ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
eautoreconf
fi
}
@@ -67,15 +71,27 @@ src_configure() {
local myeconfargs=(
# USE="test" installs .a files
--disable-static
+ --disable-werror
$(use_enable nls)
$(use_enable pam vlock)
$(use_enable test tests)
)
+
econf "${myeconfargs[@]}"
}
+src_test() {
+ # Cheesy hack for now for https://github.com/legionus/kbd/issues/76
+ mv "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map "${S}"/data/keymaps/i386/qwerty/cz.map || die
+
+ default
+
+ mv "${S}"/data/keymaps/i386/qwerty/cz.map "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map || die
+}
+
src_install() {
default
+
docinto html
dodoc docs/doc/*.html