summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-01 22:10:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-01 22:10:53 +0200
commit0f9a75eef722e5959c9eb565d26c7e2798bc3fc1 (patch)
tree6a32c13befbd3c9dc2f02175b00aa58b58fb7f59 /sys-apps/kexec-tools/files
parentsys-apps/kexec-tools: Bump to version 2.0.17 (diff)
downloadgentoo-0f9a75eef722e5959c9eb565d26c7e2798bc3fc1.tar.gz
gentoo-0f9a75eef722e5959c9eb565d26c7e2798bc3fc1.tar.bz2
gentoo-0f9a75eef722e5959c9eb565d26c7e2798bc3fc1.zip
sys-apps/kexec-tools: Removed old.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-apps/kexec-tools/files')
-rw-r--r--sys-apps/kexec-tools/files/kexec-tools-2.0.0-respect-LDFLAGS.patch11
-rw-r--r--sys-apps/kexec-tools/files/kexec.init-2.0.4-r2164
2 files changed, 0 insertions, 175 deletions
diff --git a/sys-apps/kexec-tools/files/kexec-tools-2.0.0-respect-LDFLAGS.patch b/sys-apps/kexec-tools/files/kexec-tools-2.0.0-respect-LDFLAGS.patch
deleted file mode 100644
index 040d138ece06..000000000000
--- a/sys-apps/kexec-tools/files/kexec-tools-2.0.0-respect-LDFLAGS.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- kdump/Makefile
-+++ kdump/Makefile
-@@ -18,7 +18,7 @@
- $(KDUMP): CC=$(TARGET_CC)
- $(KDUMP): $(KDUMP_OBJS)
- @$(MKDIR) -p $(@D)
-- $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o $@ $(KDUMP_OBJS)
-+ $(LINK.o) $(CFLAGS) -o $@ $(KDUMP_OBJS)
-
- $(KDUMP_MANPAGE): kdump/kdump.8
- $(MKDIR) -p $(MANDIR)/man8
diff --git a/sys-apps/kexec-tools/files/kexec.init-2.0.4-r2 b/sys-apps/kexec-tools/files/kexec.init-2.0.4-r2
deleted file mode 100644
index f60cb2a7cafa..000000000000
--- a/sys-apps/kexec-tools/files/kexec.init-2.0.4-r2
+++ /dev/null
@@ -1,164 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount
-}
-
-image_path() {
- local x= kver=$(uname -r) karch=$(uname -m)
- BOOTPART="${BOOTPART:-/boot}"
- KNAME="${KNAME:-bzImage}"
- if [ -e "${KNAME}" ]; then
- echo "${KNAME}"
- return 0
- fi
- for x in "${KNAME#${BOOTPART}}" vmlinuz \
- bzImage-${kver} vmlinuz-${kver} \
- kernel-genkernel-${karch}-${kver} \
- kernel-${kver} kernel-${karch}; do
- if [ -e "${BOOTPART}/${x}" ]; then
- echo "${BOOTPART}/${x}"
- return 0
- fi
- done
-
- return 1
-}
-
-initrd_path() {
- local x= kver=$(uname -r) karch=$(uname -m)
- BOOTPART="${BOOTPART:-/boot}"
- INITRD="${INITRD:-initrd}"
- if [ -e "${INITRD}" ]; then
- echo "${INITRD}"
- return 0
- fi
- for x in "${INITRD#${BOOTPART}}" \
- initrd.img-${kver} initrd-${kver}.img \
- initrd-${kver} initramfs-${kver}.img \
- initramfs-genkernel-${karch}-${kver} ; do
- if [ -e "${BOOTPART}/${x}" ]; then
- echo "${BOOTPART}/${x}"
- return 0
- fi
- done
-
- return 1
-}
-
-mount_boot(){
- local ret
-
- [ -n "${DONT_MOUNT_BOOT}" ] && return 1
- grep -q " ${BOOTPART:-/boot} " /proc/mounts && return 1
-
- BOOTPART="${BOOTPART:-/boot}"
- ebegin "Mounting ${BOOTPART}"
- mount "${BOOTPART}"; ret=$?
- eend ${ret}
- return ${ret}
-}
-
-load_image() {
- local ret
- if [ "${KNAME}" = "-" ]; then
- ebegin "Disabling kexec"
- kexec -u; ret=$?
- eend ${ret}
- return ${ret}
- fi
-
- BOOTPART="${BOOTPART:-/boot}"
- local img= initrd="$(initrd_path)" mounted=false initrdopt=
-
- if ! img="$(image_path)"; then
- if mount_boot; then
- if img="$(image_path)"; then
- mounted=true
- initrd="$(initrd_path)"
- else
- eerror "No kernel image found in ${BOOTPART}!"
- umount "${BOOTPART}"
- return 1
- fi
- else
- eerror "No kernel image found in ${BOOTPART}!"
- return 1
- fi
- fi
-
- if [ -n "${INITRD}" ] && \
- ! [ "${BOOTPART}/${INITRD#${BOOTPART}}" = "${initrd}" ]; then
- eerror "Requested initrd: ${INITRD#${BOOTPART}}"
- eerror "could not be found"
- return 1
- fi
-
- [ -n "${ROOTPART}" ] || \
- ROOTPART="$(readlink -f "$(sed -n '/^\/[^ ]* \/ / s,^\([^ ]*\).*,\1,p' /proc/mounts)")"
-
- [ -n "${KPARAM}" ] || KEXEC_OPT_ARGS="${KEXEC_OPT_ARGS} --reuse-cmdline"
-
- [ -n "${initrd}" ] && [ -e "${initrd}" ] && initrdopt="--initrd=${initrd}"
-
- local msg=
- [ -n "${initrd}" ] && \
- msg="with ${initrd}"
- einfo "Using kernel image ${img} ${msg} for kexec"
-
- ebegin "Setting kexec with ${KEXEC_OPT_ARGS} -l ${img} root=${ROOTPART} ${KPARAM} ${initrdopt}"
- kexec ${KEXEC_OPT_ARGS} -l "${img}" --append="root=${ROOTPART} ${KPARAM}" ${initrdopt}
- local res=$?
-
- ${mounted} && umount "${BOOTPART}"
- eend ${res}
- return ${res}
-}
-
-start() {
- if [ "${LOAD_DURING_SHUTDOWN:-yes}" = "yes" ]; then
- local ret=0
- BOOTPART="${BOOTPART:-/boot}"
- if mount_boot; then
- mounted=true
- fi
- if ! image_path > /dev/null; then
- ewarn "Cannot find kernel image!"
- ewarn "Please make sure a valid kernel image is present before reboot."
- return 0
- fi
- if [ -n "${mounted}" ]; then
- ebegin "Unmounting ${BOOTPART}"
- umount "${BOOTPART}"; ret=$?
- eend ${ret}
- fi
- return ${ret}
- else
- ebegin "Configuring kexec"
- load_image
- eend $?
- fi
-}
-
-stop() {
- [ "${LOAD_DURING_SHUTDOWN:-yes}" != "yes" ] && return 0
-
- if ! yesno $RC_REBOOT; then
- einfo "Not rebooting, so disabling"
- kexec -u
- return 0
- fi
-
- if [ -f /nokexec ]; then
- einfo "Not using kexec during reboot"
- rm -f /nokexec
- kexec -u
- return 0
- fi
-
- ebegin "Configuring kexec"
- load_image
- eend $?
-}