summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-17 09:59:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-17 09:59:37 +0200
commitda0300040918e7f732e2ffc7ccb5db6e3b03d3e9 (patch)
tree54b405bfa4c866845ae46c10b5b209f1f08cbc5a /sys-apps/less
parentsys-apps/dmidecode: Bump to version 3.2 (diff)
downloadgentoo-da0300040918e7f732e2ffc7ccb5db6e3b03d3e9.tar.gz
gentoo-da0300040918e7f732e2ffc7ccb5db6e3b03d3e9.tar.bz2
gentoo-da0300040918e7f732e2ffc7ccb5db6e3b03d3e9.zip
sys-apps/less: Bump to version 537
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-537.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 3a1c58110039..d9d0d050e484 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -3,3 +3,4 @@ DIST less-530.tar.gz 339723 BLAKE2B 9321548b06330c0b1b5b5a36147f5b9348619ff15d90
DIST less-531.tar.gz 340466 BLAKE2B 6ac75b623fce478114d18cff429659499fedf4ef1a7bb067465ace91c28a7968efb224a4994a1e376a8cf40b110492f10ecda634628029107b38187044a0cd1e SHA512 180b665f194d7cc40d4bbb37bd64b10be463c0705e81795bef84b20dbba1c61825bb3e3da8bcd79f9176bb3af7b1f4e4c3dfe0829a5a2195a11f5b42294daca1
DIST less-534.tar.gz 341351 BLAKE2B f309e486c80eb7573ebffa6cd0d43205bb517a0e1f56116ddca739fb5a94cb010157d7f64507a4e32401e28f499d25b9f1c33d160416cef8f7fba01c62cd218e SHA512 b6896061616b30ccdf4e4f03d95ed5372e912dd42832903015bb7ca1fc5596813b86581f02c6a34f6d6cc0e56f58ff62c8a7e1488a7014bd23acaca9236493fe
DIST less-535.tar.gz 341464 BLAKE2B 9093fb6c0d249fb7a6945f36c5b2fc54c407216cddc8ce4e31ad5f074fb0922f9318fd0cc1f97cc954dad4cb4a3c25fb8a25202a4e7ae7850aba5f5ce36d2b9b SHA512 23f7270d88550fa52bc7770ed25ee6631674438ecc6cd157f4a15d800405bbee21ca188119f44c7171f6d1a4bbf7f91177d815a54ffec7367e327fb8fed25584
+DIST less-537.tar.gz 341608 BLAKE2B 87425a8c0779f88d6f9029ae7ffde944d68f095dc4113a07839a523f76c96cb29bc1c076b6a0a64685ed75f86b37b47e75102663fef014027dcf1e8459c97b18 SHA512 2c4b8d2fb76843c68ee4401c373d3c01cce591a425d002d885f208b8dd4c822c5f2ee52b2fde29a5c366ed1f48cd73679c70a8329acd1cb2866a76a58b4e2063
diff --git a/sys-apps/less/less-537.ebuild b/sys-apps/less/less-537.ebuild
new file mode 100644
index 000000000000..c4d58efa2269
--- /dev/null
+++ b/sys-apps/less/less-537.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}