summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:40:43 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:40:43 +0200
commit765e7e5e80b575d727f4270f05f66358f896d30f (patch)
tree2d0c90cee764e9875b62545431442ca73d51c86f /sys-apps/logwatch
parentdev-php/pecl-ssh2: add PHP 7.3 support (diff)
downloadgentoo-765e7e5e80b575d727f4270f05f66358f896d30f.tar.gz
gentoo-765e7e5e80b575d727f4270f05f66358f896d30f.tar.bz2
gentoo-765e7e5e80b575d727f4270f05f66358f896d30f.zip
sys-apps/logwatch: bump to v7.5.1
Closes: https://bugs.gentoo.org/677536 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.5.1.ebuild95
-rw-r--r--sys-apps/logwatch/logwatch-9999.ebuild2
3 files changed, 97 insertions, 1 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index d2c2baa9dd4b..2935d869fd07 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,2 +1,3 @@
DIST logwatch-7.4.3.tar.gz 462552 BLAKE2B 98ecba949d9fa2737da6b22ff2cced14d384ff4f119a7a8e613a66869102ea76ce1093ef5f0b38e6d4e948a8e9e0dafe8b4071e028c5f5f5be2ee48e9b1f186b SHA512 716d87238f487010f2bdf230fc66c16f3c3fe769e6bef04b0e7881c6b0563e1a4b4741235b8a40a16ab21d3803562e87e6bcf5cfbd0ace42414f1d1feae7a13a
DIST logwatch-7.4.3_p20171025.zip 704529 BLAKE2B 12f4e34d9cd044f677b1b4cbe473c425e9b3ab2f222e781a0a3df95b9cbc088cf16321ccd67ec9acaa4c21b8da3deac4d58d84cba2259b272717337c5c87c3ff SHA512 aeaf57aa8d4e89b716766bf89a6b58dcb18f1ba6de864b913d93474f784f382e322b6dbfdf9671c8b91404d399d770146ead9959b1202e91b4672e70f6abb268
+DIST logwatch-7.5.1.tar.gz 469715 BLAKE2B 706352c60370d13b4f72047d08965ab0dd36837194a03bf44e08ec43641eddb8d80d655c783d4f25c8fa757853a4e069997b80676b781561c5e0a23b44a393c9 SHA512 945e66192a9e198169426497f7b5167fcbec2af9565dfead728aa91bfdac5f7e1b2ce2f5f404b6f03841fe6b978f70fb969b47d4f60f02f9a8ccea865c5c782c
diff --git a/sys-apps/logwatch/logwatch-7.5.1.ebuild b/sys-apps/logwatch/logwatch-7.5.1.ebuild
new file mode 100644
index 000000000000..eefc16389fc7
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.5.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit tmpfiles
+
+PATCHES=()
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}
diff --git a/sys-apps/logwatch/logwatch-9999.ebuild b/sys-apps/logwatch/logwatch-9999.ebuild
index 971e5d621f38..eefc16389fc7 100644
--- a/sys-apps/logwatch/logwatch-9999.ebuild
+++ b/sys-apps/logwatch/logwatch-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit tmpfiles