summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-10 16:07:13 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-10 16:07:25 +0200
commit9440d8b1aaa9c985c8faad75d5094659845c98ba (patch)
tree9072c4e89a52b12760dd590d2fffda2a7361abb9 /sys-apps/lsadb
parentapp-portage/portage-utils: version bump to v0.80 (diff)
downloadgentoo-9440d8b1aaa9c985c8faad75d5094659845c98ba.tar.gz
gentoo-9440d8b1aaa9c985c8faad75d5094659845c98ba.tar.bz2
gentoo-9440d8b1aaa9c985c8faad75d5094659845c98ba.zip
sys-apps/lsadb: Respect LDFLAGS
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-apps/lsadb')
-rw-r--r--sys-apps/lsadb/files/lsadb-makefile.patch6
-rw-r--r--sys-apps/lsadb/lsadb-0.1.3-r1.ebuild27
2 files changed, 30 insertions, 3 deletions
diff --git a/sys-apps/lsadb/files/lsadb-makefile.patch b/sys-apps/lsadb/files/lsadb-makefile.patch
index fb396cc85b22..08faacceb8a2 100644
--- a/sys-apps/lsadb/files/lsadb-makefile.patch
+++ b/sys-apps/lsadb/files/lsadb-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.bak 2009-11-30 14:31:07.000000000 -0500
-+++ Makefile 2009-11-30 14:31:34.000000000 -0500
+--- a/Makefile
++++ b/Makefile
@@ -1,6 +1,2 @@
-
-
@@ -7,4 +7,4 @@
- gcc -Wall -O2 -o $@ $< && strip $@
-
-
-+ ${CC} -Wall ${CFLAGS} -o $@ $<
++ ${CC} -Wall $(CFLAGS) $(LDFLAGS) -o $@ $<
diff --git a/sys-apps/lsadb/lsadb-0.1.3-r1.ebuild b/sys-apps/lsadb/lsadb-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..aa0234ff5eaf
--- /dev/null
+++ b/sys-apps/lsadb/lsadb-0.1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Prints out information on all devices attached to the ADB bus"
+HOMEPAGE="http://pbbuttons.berlios.de/projects/lsadb/"
+#SRC_URI="mirror://berlios/pub/pbbuttons/${PN}-${PV}.tgz"
+SRC_URI="mirror://gentoo/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="-* ~ppc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-makefile.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin lsadb
+ doman lsadb.1
+ dodoc README
+}