summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-11 12:44:47 +0000
committerSam James <sam@gentoo.org>2022-02-11 12:44:47 +0000
commit031d2ceb8ad9275a1350b6bcc02ac49a62b52ca3 (patch)
tree1891ef052fb4295ce3b3655b20a783bcd71c8298 /sys-apps/man-db
parentsys-apps/man-db: add 2.10.1 (diff)
downloadgentoo-031d2ceb8ad9275a1350b6bcc02ac49a62b52ca3.tar.gz
gentoo-031d2ceb8ad9275a1350b6bcc02ac49a62b52ca3.tar.bz2
gentoo-031d2ceb8ad9275a1350b6bcc02ac49a62b52ca3.zip
sys-apps/man-db: drop 2.10.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/Manifest1
-rw-r--r--sys-apps/man-db/man-db-2.10.0.ebuild205
2 files changed, 0 insertions, 206 deletions
diff --git a/sys-apps/man-db/Manifest b/sys-apps/man-db/Manifest
index a380a4a7245b..b705601b6d87 100644
--- a/sys-apps/man-db/Manifest
+++ b/sys-apps/man-db/Manifest
@@ -1,3 +1,2 @@
-DIST man-db-2.10.0.tar.xz 1888196 BLAKE2B 02aed8a8d490b4e481c42790b8783768bf4adcab1430f2e06d2a1b22a4c769dd3978800e609d221da1dcc25032e096ad9ba8580e2ff8a72e8b19dbda573562b4 SHA512 de9c9f3dd9e6a578eb99aca0d04ce5c98cf6733e83e3be5299b6cafc4aad202896429a263a34111529eccdf07c353438afdade278818fc5d884471df7a4816c9
DIST man-db-2.10.1.tar.xz 1890536 BLAKE2B b052a7006e1d47dfe7b82f82b6e6e47500ca1c8fa20716af7d3d4193ebde0b109f13f4ed3148c5e4bbc76f34d457ec71bf93ed88f9ab0f5da5b5e1c9066e6d70 SHA512 25a3c4e3d7b171faf0771885a7a7d502c4af801881777231c79d7ee9768c2e48e44afbf5603af13f5ac63e6981cfdb8e36ba8a33d5f926d8122635cf45fcff7a
DIST man-db-2.9.4.tar.xz 1909020 BLAKE2B 43427e851f0e661ca1cee55211dd7636f4ffde067c75de7715f525029b22c205728f8e86ac49abff60e47a4a4c9e1fbd78e2c87e70bd37778b88594a3897275f SHA512 169f091dd0a1d0dbd1583366f8257afb8f57e030d0f7d4213c14ce0b1fc5debf8b9cf2731de503830cb2826b3a22b3cff7da993d44ec18557935bd293529133c
diff --git a/sys-apps/man-db/man-db-2.10.0.ebuild b/sys-apps/man-db/man-db-2.10.0.ebuild
deleted file mode 100644
index f49d58338bd1..000000000000
--- a/sys-apps/man-db/man-db-2.10.0.ebuild
+++ /dev/null
@@ -1,205 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd prefix tmpfiles
-
-DESCRIPTION="A man replacement that utilizes berkdb instead of flat files"
-HOMEPAGE="https://gitlab.com/cjwatson/man-db https://www.nongnu.org/man-db/"
-if [[ ${PV} == *9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitlab.com/cjwatson/man-db.git"
-else
- # TODO: Change tarballs to gitlab too...?
- SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="berkdb +manpager nls +seccomp selinux static-libs zlib"
-
-CDEPEND="!sys-apps/man
- >=dev-libs/libpipeline-1.5.0
- sys-apps/groff
- !berkdb? ( sys-libs/gdbm:= )
- berkdb? ( sys-libs/db:= )
- seccomp? ( sys-libs/libseccomp )
- zlib? ( sys-libs/zlib )"
-DEPEND="${CDEPEND}"
-BDEPEND="app-arch/xz-utils
- virtual/pkgconfig
- nls? (
- >=app-text/po4a-0.45
- sys-devel/gettext
- virtual/libiconv
- virtual/libintl
- )"
-RDEPEND="${CDEPEND}
- acct-group/man
- acct-user/man
- selinux? ( sec-policy/selinux-mandb )"
-PDEPEND="manpager? ( app-text/manpager )"
-
-PATCHES=(
- "${FILESDIR}"/man-db-2.9.3-sandbox-env-tests.patch
- "${FILESDIR}"/man-db-2.9.3-darwin-libdb-intl.patch
-
- "${FILESDIR}"/${P}-fix-build-clang.patch
-)
-
-src_unpack() {
- if [[ ${PV} == *9999 ]] ; then
- git-r3_src_unpack
-
- # We need to mess with gnulib
- EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
- EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
- git-r3_src_unpack
- else
- default
- fi
-}
-
-src_prepare() {
- default
-
- if [[ "${PV}" == *9999 ]] ; then
- local bootstrap_opts=(
- --gnulib-srcdir=../gnulib
- --no-bootstrap-sync
- --copy
- --no-git
- )
- AUTORECONF="/bin/true" \
- LIBTOOLIZE="/bin/true" \
- sh ./bootstrap "${bootstrap_opts[@]}" || die
-
- eautoreconf
- fi
-
- hprefixify src/man_db.conf.in
- if use prefix ; then
- {
- echo "#"
- echo "# Added settings for Gentoo Prefix"
- [[ ${CHOST} == *-darwin* ]] && \
- echo "MANDATORY_MANPATH ${EPREFIX}/MacOSX.sdk/usr/share/man"
- echo "MANDATORY_MANPATH /usr/share/man"
- } >> src/man_db.conf.in
- fi
-}
-
-src_configure() {
- # Set sections we want to search by default
- local sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o"
- sections+=" 1x 2x 3x 4x 5x 6x 7x 8x"
- case ${CHOST} in
- *-solaris*)
- # Solaris tends to use sections named after the pkgs that
- # owns them, in particular for libc functions we want those
- # sections
- local s
- for s in $(cd /usr/share/man/ && echo man*) ; do
- s=${s#man}
- [[ " ${sections} " != *" ${s} "* ]] && sections+=" ${s}"
- done
- ;;
- esac
-
- export ac_cv_lib_z_gzopen=$(usex zlib)
- local myeconfargs=(
- --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
- --disable-setuid # bug #662438
- --enable-cache-owner=man
- --with-sections="${sections}"
-
- $(use_enable nls)
- $(use_enable static-libs static)
- $(use_with seccomp libseccomp)
-
- --with-db=$(usex berkdb db gdbm)
- )
-
- case ${CHOST} in
- *-solaris*|*-darwin*)
- myeconfargs+=(
- $(use_with nls libiconv-prefix "${EPREFIX}"/usr)
- $(use_with nls libintl-prefix "${EPREFIX}"/usr)
- )
- ;;
- esac
-
- econf "${myeconfargs[@]}"
-
- # Disable color output from groff so that the manpager can add it. bug #184604
- sed -i \
- -e '/^#DEFINE.*\<[nt]roff\>/{s:^#::;s:$: -c:}' \
- src/man_db.conf || die
-
- cat > 15man-db <<-EOF || die
- SANDBOX_PREDICT="/var/cache/man"
- EOF
-}
-
-src_install() {
- default
- dodoc docs/{HACKING.md,TODO}
- find "${ED}" -type f -name "*.la" -delete || die
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/man-db.cron-r1 man-db # bug #289884
-
- insinto /etc/sandbox.d
- doins 15man-db
-}
-
-pkg_preinst() {
- local cachedir="${EROOT}/var/cache/man"
- # If the system was already exploited, and the attacker is hiding in the
- # cachedir of the old man-db, let's wipe them out.
- # see bug #602588 comment 18
- local _replacing_version=
- local _setgid_vuln=0
- for _replacing_version in ${REPLACING_VERSIONS} ; do
- if ver_test '2.7.6.1-r2' -le "${_replacing_version}" ; then
- debug-print "Skipping security bug #602588 ... existing installation (${_replacing_version}) should not be affected!"
- else
- _setgid_vuln=1
- debug-print "Applying cleanup for security bug #602588"
- fi
- done
- [[ ${_setgid_vuln} -eq 1 ]] && rm -rf "${cachedir}"
-
- # Fall back to recreating the cachedir
- if [[ ! -d ${cachedir} ]] ; then
- mkdir -p "${cachedir}" || die
- chown man:man "${cachedir}" || die
- fi
-
- # Update the whatis cache
- if [[ -f ${cachedir}/whatis ]] ; then
- einfo "Cleaning ${cachedir} from sys-apps/man"
- find "${cachedir}" -type f '!' '(' -name index.bt -o -name index.db ')' -delete
- fi
-}
-
-pkg_postinst() {
- tmpfiles_process man-db.conf
-
- if [[ -n "${REPLACING_VERSIONS}" ]] ; then
- local _replacing_version=
-
- for _replacing_version in ${REPLACING_VERSIONS} ; do
- if [[ $(ver_cut 2 ${_replacing_version}) -lt 7 ]] ; then
- einfo "Rebuilding man-db from scratch with new database format!"
- su man -s /bin/sh -c 'mandb --quiet --create' 2>/dev/null
-
- # No need to run it again if we hit one
- break
- fi
- done
- fi
-}