summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-26 22:31:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-26 22:33:52 +0200
commitcf819c997c67fd3f2eaf4f7c52efd64d2668403e (patch)
treef1a6840fd9db4fc03f1243ff573a41c061831faa /sys-apps/man-db
parentnet-misc/rdesktop: backport fix for some failing connections (diff)
downloadgentoo-cf819c997c67fd3f2eaf4f7c52efd64d2668403e.tar.gz
gentoo-cf819c997c67fd3f2eaf4f7c52efd64d2668403e.tar.bz2
gentoo-cf819c997c67fd3f2eaf4f7c52efd64d2668403e.zip
sys-apps/man-db: Bump to version 2.8.7
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/Manifest1
-rw-r--r--sys-apps/man-db/man-db-2.8.7.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/sys-apps/man-db/Manifest b/sys-apps/man-db/Manifest
index 3e3eb2319b42..e128566ce670 100644
--- a/sys-apps/man-db/Manifest
+++ b/sys-apps/man-db/Manifest
@@ -1,3 +1,4 @@
DIST man-db-2.7.6.1.tar.xz 1541316 BLAKE2B ea3aa7e90ea8af4882bd99d99374cc37d9c0c7f70bb970973eb3f2178aa4323bcdebc7f39f142ec0144dbe55a9f86aba15d9fe281d2662d280b8e6dca9452f24 SHA512 623c5e7f8b7c289908b2c926f8777293b8d39aeceef0d2509d701a8b0bfa81408650f655c8608318221786c751a79ee91124b07993de5298cd7fa6d8bb737301
DIST man-db-2.8.5.tar.xz 1787244 BLAKE2B b908a6fb0187d42f8d1f842063e0afdf1e052244ea727f0aaaf4d658bb8954a216c0555df5511b27246fd12c2a388c44dcfccf243449d25d6e741c5c3466d3be SHA512 8d1524c3b6459c9ac02d969149c18c198cb171bcd6acc493e863a466c01309958ee9f5ac52df4d7d27da29d35cb7c64132732f5b969181ab336500df2e6dad69
DIST man-db-2.8.6.1.tar.xz 1829328 BLAKE2B 5dce50a4d5003a370595b3db0b1d7f01c54b53d26f011307bd91447cdeed410ea20a6720b12eae301d21c0b9674ed84b055f38f44e09d5543ce1647dff8b5bca SHA512 0c43cdddf2e07cd4a2225e098ea4cbfb2842a9bbf08bfb073058be0d66efac3a77ca0f8725564677c8f61e671f471c76f1dbba77a7601d7a63bb81350ef51bb5
+DIST man-db-2.8.7.tar.xz 1839012 BLAKE2B 19b438b1083cfd838421f29ed053fe85686929bc9f2105fe399ea99622f138bca2c8888a17cddb9223362db2d5f9c4bb3669865ecf749fe845ea8e4223027f67 SHA512 9f9d6f3b776c0b35f95c179fb668f2dc3db3d3e63a162cfda98c5d126fe147f2418e1a1503037ebe28314f57d9b6f48b7f7674d611df14424973a866a61ff2d9
diff --git a/sys-apps/man-db/man-db-2.8.7.ebuild b/sys-apps/man-db/man-db-2.8.7.ebuild
new file mode 100644
index 000000000000..4d2bfc884fe9
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.8.7.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/man-db.git"
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb +gdbm +manpager nls +seccomp selinux static-libs zlib"
+
+CDEPEND="
+ !sys-apps/man
+ >=dev-libs/libpipeline-1.5.0
+ sys-apps/groff
+ berkdb? ( sys-libs/db:= )
+ gdbm? ( sys-libs/gdbm:= )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm:= ) )
+ seccomp? ( sys-libs/libseccomp )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ >=app-text/po4a-0.45
+ sys-devel/gettext
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ acct-group/man
+ acct-user/man
+ selinux? ( sec-policy/selinux-mandb )
+"
+PDEPEND="manpager? ( app-text/manpager )"
+
+pkg_setup() {
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ local myeconfargs=(
+ --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --disable-setuid #662438
+ --enable-cache-owner=man
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x"
+ $(use_enable nls)
+ $(use_enable static-libs static)
+ $(use_with seccomp libseccomp)
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+ )
+ econf "${myeconfargs[@]}"
+
+ # Disable color output from groff so that the manpager can add it. #184604
+ sed -i \
+ -e '/^#DEFINE.*\<[nt]roff\>/{s:^#::;s:$: -c:}' \
+ src/man_db.conf || die
+
+ cat > 15man-db <<-EOF || die
+ SANDBOX_PREDICT="/var/cache/man"
+ EOF
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ find "${ED}" -name "*.la" -delete || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron-r1 man-db #289884
+
+ insinto /etc/sandbox.d
+ doins 15man-db
+}
+
+pkg_preinst() {
+ local cachedir="${EROOT}/var/cache/man"
+ # If the system was already exploited, and the attacker is hiding in the
+ # cachedir of the old man-db, let's wipe them out.
+ # see bug #602588 comment 18
+ local _replacing_version=
+ local _setgid_vuln=0
+ for _replacing_version in ${REPLACING_VERSIONS}; do
+ if ver_test '2.7.6.1-r2' -le "${_replacing_version}"; then
+ debug-print "Skipping security bug #602588 ... existing installation (${_replacing_version}) should not be affected!"
+ else
+ _setgid_vuln=1
+ debug-print "Applying cleanup for security bug #602588"
+ fi
+ done
+ [[ ${_setgid_vuln} -eq 1 ]] && rm -rf "${cachedir}"
+
+ # Fall back to recreating the cachedir
+ if [[ ! -d ${cachedir} ]] ; then
+ mkdir -p "${cachedir}" || die
+ chown man:man "${cachedir}" || die
+ fi
+
+ # Update the whatis cache
+ if [[ -f ${cachedir}/whatis ]] ; then
+ einfo "Cleaning ${cachedir} from sys-apps/man"
+ find "${cachedir}" -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+}
+
+pkg_postinst() {
+ if [[ $(ver_cut 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
+ einfo "Rebuilding man-db from scratch with new database format!"
+ su man -s /bin/sh -c 'mandb --quiet --create' 2>/dev/null
+ fi
+}