summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-02 23:20:25 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-02 23:22:31 -0500
commit4ccc6604de4e6dd4946e8b41cdaad9aeb226d858 (patch)
tree397495e131972801c6a191f6dd6631202ec8eff4 /sys-apps/moreutils
parentmedia-sound/abcm2ps: version bump to 8.14.4 (diff)
downloadgentoo-4ccc6604de4e6dd4946e8b41cdaad9aeb226d858.tar.gz
gentoo-4ccc6604de4e6dd4946e8b41cdaad9aeb226d858.tar.bz2
gentoo-4ccc6604de4e6dd4946e8b41cdaad9aeb226d858.zip
sys-apps/moreutils: version bump to 0.63
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-apps/moreutils')
-rw-r--r--sys-apps/moreutils/Manifest1
-rw-r--r--sys-apps/moreutils/moreutils-0.63.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index 376459ac9ad9..8ad2a12b626d 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1,2 +1,3 @@
DIST moreutils-0.61.tar.gz 93234 BLAKE2B cfa3c24d68ca0f9ef220ef97e0ac50a77e557cc399ef898d15a56d4e205ba180f494ca7a89a566e4dea28eebf08590fbd94b75f7850f941a8a22eba147f8e61d SHA512 6164680c8bfec02f7a84274b1d4342a1d6c296e14843496dcc9f9ac71b3e3b1663dea72e2251a546a646775afa70589483e8d5da71b388b1022476bb3dd91b56
DIST moreutils-0.62.tar.gz 93711 BLAKE2B b8d8cf7c83c3a9fc6a3fb1677954520dcc884ba81eebdf7cde2232f8aea7177f4c79dbce84ff20cf20f924af279c6e02683dfd082ad35237cc0109cddfe30e14 SHA512 100d8129572c1b9ef1381150b69cbcd1762700e66c0ffa0ea849989352bc1bad77b67c5dbc00c159ca6c02905585dbfa3c8a5d88e910da9daaf27b5dba9f2367
+DIST moreutils_0.63.orig.tar.xz 80468 BLAKE2B 39efa522c5bf9b982b70c1180f622a7d5a489cabbeb741f2a1a0674dfe9907ef85bccccf9f9cc4ae8d3c81442b1513f0692c070b4c00f052135528dc0e47eb6f SHA512 71bd5ec4d265dff708db372189146acb067c4edaf62888755d245ccb3f4b5bb54f6c31bda68991f78c27ab231de8ea7126f947834f3604b60d7142d0357cb66b
diff --git a/sys-apps/moreutils/moreutils-0.63.ebuild b/sys-apps/moreutils/moreutils-0.63.ebuild
new file mode 100644
index 000000000000..a52e8ef948fe
--- /dev/null
+++ b/sys-apps/moreutils/moreutils-0.63.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a collection of tools that nobody thought to write when Unix was young"
+HOMEPAGE="https://joeyh.name/code/moreutils/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="+doc +perl"
+
+RDEPEND="
+ perl? (
+ dev-lang/perl
+ dev-perl/IPC-Run
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ )"
+DEPEND="
+ app-admin/eselect
+ doc? (
+ dev-lang/perl
+ >=app-text/docbook2X-0.8.8-r2
+ app-text/docbook-xml-dtd:4.4
+ )"
+
+src_prepare() {
+ # don't build manpages
+ if ! use doc ; then
+ sed -i -e '/^all:/s/$(MANS)//' -e '/man1/d' Makefile || die
+ fi
+
+ # don't install perl scripts
+ if ! use perl ; then
+ sed -i -e '/PERLSCRIPTS/d' Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" DOCBOOKXSL=/usr/share/sgml/docbook/xsl-stylesheets PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" INSTALL_BIN=install install
+
+ # sys-process is more advanced than parallel from moreutils, rename it
+ if use doc; then
+ mv "${ED}"/usr/share/man/man1/{,${PN}_}parallel.1 || die
+ fi
+ mv "${ED}"/usr/bin/{,${PN}_}parallel || die
+}
+
+pkg_postinst() {
+ # try to make sure $EDITOR is valid for vipe (bug #604630)
+ eselect editor update
+}