summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-07-08 18:28:52 -0700
committerZac Medico <zmedico@gentoo.org>2016-07-08 18:31:56 -0700
commit977efc7497b87d24b66c6e1a2b1f82d0fe70f3fd (patch)
treed849683ab8d15c45965fb76076ba47150cd44de0 /sys-apps/nvme-cli/nvme-cli-0.8.ebuild
parentmedia-libs/mesa: Version bump to 12.0.1. (diff)
downloadgentoo-977efc7497b87d24b66c6e1a2b1f82d0fe70f3fd.tar.gz
gentoo-977efc7497b87d24b66c6e1a2b1f82d0fe70f3fd.tar.bz2
gentoo-977efc7497b87d24b66c6e1a2b1f82d0fe70f3fd.zip
sys-apps/nvme-cli: version bump to 0.8
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/nvme-cli/nvme-cli-0.8.ebuild')
-rw-r--r--sys-apps/nvme-cli/nvme-cli-0.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/nvme-cli/nvme-cli-0.8.ebuild b/sys-apps/nvme-cli/nvme-cli-0.8.ebuild
new file mode 100644
index 000000000000..4db21880ef59
--- /dev/null
+++ b/sys-apps/nvme-cli/nvme-cli-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="NVM-Express user space tooling for Linux"
+HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
+SRC_URI="https://github.com/linux-nvme/nvme-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed 's|-m64 \(-std=gnu99\) -O2 -g \(-pthread -D_GNU_SOURCE -D_REENTRANT -Wall\) -Werror|\1 \2|' \
+ -i Makefile || die
+ sed 's|/usr/local|$(DESTDIR)/$(PREFIX)/share|' \
+ -i Documentation/Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}