summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2018-04-30 22:40:30 +0900
committerBenda Xu <heroxbd@gentoo.org>2018-04-30 22:52:17 +0900
commit744bd9bc87bda99a06e0e93513bef5cf0cf95b13 (patch)
treedb27bc9ed061ed82b651cd58ad134a31d0c57545 /sys-apps/opentmpfiles
parentvirtual/perl-Term-ReadLine: Add missing '*' (diff)
downloadgentoo-744bd9bc87bda99a06e0e93513bef5cf0cf95b13.tar.gz
gentoo-744bd9bc87bda99a06e0e93513bef5cf0cf95b13.tar.bz2
gentoo-744bd9bc87bda99a06e0e93513bef5cf0cf95b13.zip
sys-apps/opentmpfiles: apply 68549620 to -9999.
Suggested-By: Askar Bektassov Bug: https://bugs.gentoo.org/644484 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-apps/opentmpfiles')
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/opentmpfiles/opentmpfiles-9999.ebuild b/sys-apps/opentmpfiles/opentmpfiles-9999.ebuild
index 1577a7364fc9..cd2b8eff44b1 100644
--- a/sys-apps/opentmpfiles/opentmpfiles-9999.ebuild
+++ b/sys-apps/opentmpfiles/opentmpfiles-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit prefix
if [[ ${PV} = 9999* ]]; then
inherit git-r3
@@ -22,8 +23,13 @@ IUSE="selinux"
RDEPEND="!<sys-apps/openrc-0.23
selinux? ( sec-policy/selinux-base-policy )"
-src_install() {
+src_prepare() {
default
+ hprefixify tmpfiles
+}
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
cd openrc
for f in opentmpfiles-dev opentmpfiles-setup; do
newconfd ${f}.confd ${f}