summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-10-25 14:53:48 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-10-25 14:56:41 -0500
commit9b3bddffffc253ca42d5daefd1858e261509a340 (patch)
treebf5b54300e9b5300310e183e0448531c128b3dff /sys-apps/opentmpfiles
parentdev-python/irc: Stabilize 19.0.1 ALLARCHES, #750623 (diff)
downloadgentoo-9b3bddffffc253ca42d5daefd1858e261509a340.tar.gz
gentoo-9b3bddffffc253ca42d5daefd1858e261509a340.tar.bz2
gentoo-9b3bddffffc253ca42d5daefd1858e261509a340.zip
sys-apps/opentmpfiles: remove broken 0.3 version
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps/opentmpfiles')
-rw-r--r--sys-apps/opentmpfiles/Manifest1
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/opentmpfiles/Manifest b/sys-apps/opentmpfiles/Manifest
index 7f24de988e0d..dfc521262545 100644
--- a/sys-apps/opentmpfiles/Manifest
+++ b/sys-apps/opentmpfiles/Manifest
@@ -3,4 +3,3 @@ DIST opentmpfiles-0.1.2.tar.gz 5614 BLAKE2B d49485535bc3b92ba7e9a2af511969b1793d
DIST opentmpfiles-0.1.3.tar.gz 5691 BLAKE2B 56d79f0279a46ed3b4e13f94a7f2c7d494df245a17b8533c48cff357c21db56485bd076e375f3b4e2c9a140a65e8ab472a8a1030bbee0853463f734c316f71e8 SHA512 fd0b10ebfeb621466edadede50ec6e8f415861ab3b14b833c75bd71f7296e9c091e59144d39e1f9efd342b6d97776cade5a692c941085e33e9651fd885da7121
DIST opentmpfiles-0.2.tar.gz 5711 BLAKE2B e1ee7820b2d184d18e63e7e9d93227bb301eb82be8c2b6021c7a1092f55a4ca2bb5dfb7494ff00c3b6debace1963f6c89011ff557f665f0a93c907bd759a4c6f SHA512 bc384cc9156ba6c54d3308ddad4d26b1877f020aa8558e82df2ed49ffa65e0fed5a49eaa11b27193bfe2ad11a4d7368f7cdbc225b820b309af3b299327ddb07b
DIST opentmpfiles-0.3.1.tar.gz 6843 BLAKE2B 20cb40b34fd8db37da5797dc25912000f7d1feb38952b99c044220666cb21871eb40d3853074cb33ee8bcce8dc4858d102aeccb5730ce28df47e99a7edb50f2d SHA512 1e0985403013ac10c0fe50a7ba61a250357b1ea7ea426f9dc92d7071e97eb0e5209448550cf427734b917599defa5123254044d5352b9dcaa22e562e5ca6821f
-DIST opentmpfiles-0.3.tar.gz 6831 BLAKE2B bed680dbbf3915086fcd9c47f8fadb25049b4b5f0687b623ece73ae2c40183ba10646c5bc32ec6c8a3d0c493f9a59f16de3d90cf17aa4add6caeead011c665c6 SHA512 02f12d03b75d3df84755dbea2fa27a075ae2b12eb34189aaa532b2b085fb1f455aaf6cc84d56eb7f299fd90922f704fcf0a585f983a7e14dbf843e2ab62de387
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild
deleted file mode 100644
index 1bdbb4ca4146..000000000000
--- a/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit prefix
-
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/openrc/${PN}"
-else
- SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
- ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
-HOMEPAGE="https://github.com/openrc/opentmpfiles"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="selinux"
-
-RDEPEND="!<sys-apps/openrc-0.23
- selinux? ( sec-policy/selinux-base-policy )"
-
-src_prepare() {
- default
- hprefixify tmpfiles
-}
-src_install() {
- emake DESTDIR="${ED}" install
- einstalldocs
- cd openrc
- for f in opentmpfiles-dev opentmpfiles-setup; do
- newconfd ${f}.confd ${f}
- newinitd ${f}.initd ${f}
- done
-}
-
-add_service() {
- local initd=$1
- local runlevel=$2
-
- elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
- mkdir -p "${EROOT}"etc/runlevels/${runlevel}
- ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
-}
-
-pkg_postinst() {
- if [[ -z $REPLACING_VERSIONS ]]; then
- add_service opentmpfiles-dev sysinit
- add_service opentmpfiles-setup boot
- fi
-}