summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-20 13:57:14 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-20 14:00:44 +0100
commit7bd5f7e64b50b7b6e5b0f20b6fc176b2e6beed37 (patch)
treedae351ba298707075d2e31989ba294febcdcd796 /sys-apps/pkgcore
parentdev-python/lxml: Enable py3.8 (diff)
downloadgentoo-7bd5f7e64b50b7b6e5b0f20b6fc176b2e6beed37.tar.gz
gentoo-7bd5f7e64b50b7b6e5b0f20b6fc176b2e6beed37.tar.bz2
gentoo-7bd5f7e64b50b7b6e5b0f20b6fc176b2e6beed37.zip
sys-apps/pkgcore: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 670df92a2cf7..f4d238d16460 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -30,10 +30,15 @@ else
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
python_compile_all() {
local esetup_args=( $(usex doc "--enable-html-docs" "") )
# only build man pages for live ebuilds if doc USE flag is enabled