summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 15:57:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 16:17:56 +0100
commit7efa28d485458743e6c25201b75526628f341af6 (patch)
tree9e5c5db174cb742e49efe20b47507e62aa3097cb /sys-apps/pmount
parentdev-util/squashmerge: Bump to EAPI 7 (diff)
downloadgentoo-7efa28d485458743e6c25201b75526628f341af6.tar.gz
gentoo-7efa28d485458743e6c25201b75526628f341af6.tar.bz2
gentoo-7efa28d485458743e6c25201b75526628f341af6.zip
sys-apps/pmount: Bump to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/files/pmount-0.9.19-testsuite-missing-dir.patch6
-rw-r--r--sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch4
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild27
3 files changed, 20 insertions, 17 deletions
diff --git a/sys-apps/pmount/files/pmount-0.9.19-testsuite-missing-dir.patch b/sys-apps/pmount/files/pmount-0.9.19-testsuite-missing-dir.patch
index 93d0555f0f3d..319a1d6f04a3 100644
--- a/sys-apps/pmount/files/pmount-0.9.19-testsuite-missing-dir.patch
+++ b/sys-apps/pmount/files/pmount-0.9.19-testsuite-missing-dir.patch
@@ -16,21 +16,21 @@ diff --git a/tests/check_fstab/a b/tests/check_fstab/a
new file mode 100644
index 0000000..d16d1c5
--- /dev/null
-+++ tests/check_fstab/a
++++ b/tests/check_fstab/a
@@ -0,0 +1 @@
+This file is a 'dummy device file' for the fstab check
diff --git a/tests/check_fstab/d b/tests/check_fstab/d
new file mode 100644
index 0000000..d16d1c5
--- /dev/null
-+++ tests/check_fstab/d
++++ b/tests/check_fstab/d
@@ -0,0 +1 @@
+This file is a 'dummy device file' for the fstab check
diff --git a/tests/check_fstab/fstab b/tests/check_fstab/fstab
new file mode 100644
index 0000000..8ba6f6c
--- /dev/null
-+++ tests/check_fstab/fstab
++++ b/tests/check_fstab/fstab
@@ -0,0 +1,6 @@
+# A dummy fstab file for
+
diff --git a/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch b/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch
index c96fc0554522..3dabd03c9659 100644
--- a/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch
+++ b/sys-apps/pmount/files/pmount-0.9.99_alpha-locale-regex.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/416985
---- src/conffile.c
-+++ src/conffile.c
+--- a/src/conffile.c
++++ b/src/conffile.c
@@ -372,7 +372,7 @@ static int cf_prepare_regexps()
/* A regexp matching a boolean value*/
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
index 52df8b15b9ff..7df482af2a2e 100644
--- a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils bash-completion-r1
+EAPI=7
+inherit bash-completion-r1
DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
HOMEPAGE="https://launchpad.net/pmount"
SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV/_/-}.orig.tar.bz2"
+S=${WORKDIR}/${P/_/-}
LICENSE="GPL-2"
SLOT="0"
@@ -21,21 +22,22 @@ DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext"
-S=${WORKDIR}/${P/_/-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch
+ "${FILESDIR}"/${P}-locale-regex.patch
+)
src_prepare() {
# Restore default value from pmount <= 0.9.23 wrt #393633
sed -i -e '/^not_physically_logged_allow/s:=.*:= yes:' etc/pmount.conf || die
- cat <<-EOF > po/POTFILES.skip
+ cat <<-EOF > po/POTFILES.skip || die
src/conffile.c
src/configuration.c
src/loop.c
EOF
- epatch \
- "${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch \
- "${FILESDIR}"/${P}-locale-regex.patch
+ default
}
src_configure() {
@@ -45,14 +47,15 @@ src_configure() {
src_test() {
local testdir=${S}/tests/check_fstab
- ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
- ln -s $testdir/c $testdir/e \
- || die "Unable to create fake symlinks required for testsuite"
+ ln -s a "${testdir}/b" &&
+ ln -s d "${testdir}/c" &&
+ ln -s c "${testdir}/e" ||
+ die "Unable to create fake symlinks required for testsuite"
emake check
}
-src_install () {
+src_install() {
# Must be run SETUID+SETGID, bug #250106
exeinto /usr/bin
exeopts -m 6710 -g plugdev