summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2019-03-04 21:37:09 -0500
committerPatrice Clement <monsieurp@gentoo.org>2019-03-18 23:48:30 +0100
commit4168b723fc0979e22c6fbd1b39e71b47c109a5f4 (patch)
tree14fb73cc58c20840765c0f6f14b93094d648282e /sys-apps/proot
parentdev-db/postgresql: stable 10.7 for sparc, bug #680840 (diff)
downloadgentoo-4168b723fc0979e22c6fbd1b39e71b47c109a5f4.tar.gz
gentoo-4168b723fc0979e22c6fbd1b39e71b47c109a5f4.tar.bz2
gentoo-4168b723fc0979e22c6fbd1b39e71b47c109a5f4.zip
sys-apps/proot: update metadata, add 9999 version.
Closes: https://bugs.gentoo.org/675460 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/11261 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-apps/proot')
-rw-r--r--sys-apps/proot/metadata.xml10
-rw-r--r--sys-apps/proot/proot-5.1.0-r2.ebuild (renamed from sys-apps/proot/proot-5.1.0-r1.ebuild)21
2 files changed, 20 insertions, 11 deletions
diff --git a/sys-apps/proot/metadata.xml b/sys-apps/proot/metadata.xml
index d2757b2e50de..f8c3c4c12811 100644
--- a/sys-apps/proot/metadata.xml
+++ b/sys-apps/proot/metadata.xml
@@ -12,13 +12,11 @@
transparently through QEMU user-mode.
</longdescription>
<upstream>
- <remote-id type="github">cedric-vincent/PRoot</remote-id>
- <maintainer>
- <email>gentoo@reproducible.io</email>
- <name>Cédric Vincent</name>
- </maintainer>
+ <bugs-to>mailto:proot_me@googlegroups.com</bugs-to>
+ <changelog>https://raw.githubusercontent.com/proot-me/PRoot/master/doc/proot/changelog.txt</changelog>
+ <remote-id type="github">proot-me/PRoot</remote-id>
</upstream>
<use>
- <flag name="care">Build dynamic CARE binary (more info - http://reproducible.io/)</flag>
+ <flag name="care">Build dynamic CARE binary (more info - https://proot-me.github.io)</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/proot/proot-5.1.0-r1.ebuild b/sys-apps/proot/proot-5.1.0-r2.ebuild
index d8436f733386..ac2eea07dbf7 100644
--- a/sys-apps/proot/proot-5.1.0-r1.ebuild
+++ b/sys-apps/proot/proot-5.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,14 +6,20 @@ MY_PN="PRoot"
inherit eutils toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/proot-me/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="User-space implementation of chroot, mount --bind, and binfmt_misc"
-HOMEPAGE="https://proot-me.github.io/"
-SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://proot-me.github.io"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="care test"
+IUSE="care static test"
RDEPEND="care? ( app-arch/libarchive:0= )
sys-libs/talloc"
@@ -32,6 +38,11 @@ PATCHES=(
"${FILESDIR}/${PN}-5.1.0-loader.patch"
)
+src_prepare() {
+ default
+ use static && append-ldflags -static
+}
+
src_compile() {
# build the proot and care targets
emake -C src V=1 \