summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-08-09 18:55:42 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-08-10 08:57:06 +0200
commit547e52a3f7eb2e8fc14ba7a706c72c8f2f61e62e (patch)
tree3400540c535912de4b87ecbbd920291849933b35 /sys-apps/qdirstat
parentdev-libs/xapian: remove older unstable version (diff)
downloadgentoo-547e52a3f7eb2e8fc14ba7a706c72c8f2f61e62e.tar.gz
gentoo-547e52a3f7eb2e8fc14ba7a706c72c8f2f61e62e.tar.bz2
gentoo-547e52a3f7eb2e8fc14ba7a706c72c8f2f61e62e.zip
sys-apps/qdirstat: New package.
QDirStat is a graphical application to show where your disk space has gone and to help you clean it up. This is a Qt-only port of the old Qt3/KDE3-based KDirStat, now based on the latest Qt 5. It does not need any KDE libs or infrastructure. It runs on every X11-based desktop on Linux, BSD and other Unix-like systems. Gentoo-Bug: https://bugs.gentoo.org/583938 Base for ebuild from Märt Bakhoff in bug report Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2051 Signed-off-by: Jonathan Scruggs <j.scruggs@gmail.com> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest1
-rw-r--r--sys-apps/qdirstat/metadata.xml24
-rw-r--r--sys-apps/qdirstat/qdirstat-1.0.ebuild28
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
new file mode 100644
index 000000000000..014cb28539b1
--- /dev/null
+++ b/sys-apps/qdirstat/Manifest
@@ -0,0 +1 @@
+DIST qdirstat-1.0.tar.gz 805110 SHA256 b8404af004606a9d0e7f3a35bb28f6629a8c84620549fcab8898a551cc07b3a4 SHA512 9e98ea690fd84b435f1b4078c79350a7c0ee6b48560dc500fc9410633a650539c2db16f0526e181700580de0ee8b3044d1219eafc9870cd7e421511159b6d11d WHIRLPOOL 222945223109e9fc6bc2ae1dedeb5e55da4833be688abc14fc884bdd7ed566446d328142b770cebb0438aef52bcc1b48609f45790fc8efdbe36d96b609f9db29
diff --git a/sys-apps/qdirstat/metadata.xml b/sys-apps/qdirstat/metadata.xml
new file mode 100644
index 000000000000..ba1e21118ec3
--- /dev/null
+++ b/sys-apps/qdirstat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>j.scruggs@gmail.com</email>
+ <name>Jonathan Scruggs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Qt-based directory statistics: KDirStat without any KDE -- from
+ the author of the original KDirStat.
+
+ QDirStat is a graphical application to show where your disk space
+ has gone and to help you to clean it up.
+
+ This is a Qt-only port of the old Qt3/KDE3-based KDirStat, now
+ based on the latest Qt 5. It does not need any KDE libs or
+ infrastructure. It runs on every X11-based desktop on Linux, BSD
+ and other Unix-like systems.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/qdirstat/qdirstat-1.0.ebuild b/sys-apps/qdirstat/qdirstat-1.0.ebuild
new file mode 100644
index 000000000000..e8b2695ba6f2
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt app to show where your disk space has gone and to help you clean it up"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}