summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-04-26 18:51:32 +0800
committerJason Zaman <perfinion@gentoo.org>2018-04-26 19:22:31 +0800
commit55487cee59bc643e08d16cfc3f1284bc0f88fad1 (patch)
treed6b9581b54c4b82a4bc896a6ad363375235a84b3 /sys-apps/restorecond
parentsys-apps/mcstrans: bump to 2.8_rc1 (diff)
downloadgentoo-55487cee59bc643e08d16cfc3f1284bc0f88fad1.tar.gz
gentoo-55487cee59bc643e08d16cfc3f1284bc0f88fad1.tar.bz2
gentoo-55487cee59bc643e08d16cfc3f1284bc0f88fad1.zip
sys-apps/restorecond: bump to 2.8_rc1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--sys-apps/restorecond/restorecond-2.8_rc1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index 52ee8ec1d46e..bd23c8ee4aa6 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1 +1,2 @@
DIST restorecond-2.7.tar.gz 17753 BLAKE2B 793a41dbfd0a33d79e15c62e79f4fbbacc4208a8f2057813d7c3e2d16a3435c12e0c29ca60a3b45cef33ec13b5aacd28c8ad95ddcbf47a812654d3a59fcb6c89 SHA512 c81950e4f748a729c8951b13a4075ab1003530f8ada7a9d3fbe6428f76070df4819a37daaab557b63fc234aa8c8320ec41757fbdb24b76fa2c11747bde0038ad
+DIST restorecond-2.8-rc1.tar.gz 17778 BLAKE2B 7f0c3da54555f1bd015e191ab762d5564e8e40d1aceafa94fc774c0864f9ff720c468679a60869dc94280e89a160369afcdf2172a6aaee1b0ce555dc204cd957 SHA512 9b90485998bbabeb26d1ca197b78dadc2ad4aa15fc3eb30f16809e631009ce07f2a624d8e0c139cb6ea831ff46068de2744168c6ee0414693716b4963c8e3be9
diff --git a/sys-apps/restorecond/restorecond-2.8_rc1.ebuild b/sys-apps/restorecond/restorecond-2.8_rc1.ebuild
new file mode 100644
index 000000000000..78002784e9c6
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-2.8_rc1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20180419"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/dbus-glib
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}