summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-03-31 01:07:30 +0800
committerJason Zaman <perfinion@gentoo.org>2019-03-31 21:45:30 +0800
commit99530b1aa0f28ab2a4e2e85c905177d524e62682 (patch)
treed26f0392cef5c37f52090caca73032a4bba305fe /sys-apps/restorecond
parentsys-apps/mcstrans: bump to 2.9 (diff)
downloadgentoo-99530b1aa0f28ab2a4e2e85c905177d524e62682.tar.gz
gentoo-99530b1aa0f28ab2a4e2e85c905177d524e62682.tar.bz2
gentoo-99530b1aa0f28ab2a4e2e85c905177d524e62682.zip
sys-apps/restorecond: bump to 2.9
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--sys-apps/restorecond/restorecond-2.9.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index 00d78c90f275..7cb0575c4285 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1,3 +1,4 @@
DIST restorecond-2.7.tar.gz 17753 BLAKE2B 793a41dbfd0a33d79e15c62e79f4fbbacc4208a8f2057813d7c3e2d16a3435c12e0c29ca60a3b45cef33ec13b5aacd28c8ad95ddcbf47a812654d3a59fcb6c89 SHA512 c81950e4f748a729c8951b13a4075ab1003530f8ada7a9d3fbe6428f76070df4819a37daaab557b63fc234aa8c8320ec41757fbdb24b76fa2c11747bde0038ad
DIST restorecond-2.8.tar.gz 17740 BLAKE2B ad873acbbb7c56c29a8523a42dc053ea79036a15bed71b47a690d01d4012394b5ecf74ae75b27affb4007d754935ec90246f22ef3e0b9611556ec7baf59670db SHA512 5d72336782c3ad095746f8e6fa67e36448e5e76ca29586d8fe4962c64e505fa95c1458e8fc8f7d5bd589fff71b4be3758fb0cee3dacd2ccd0bc8476423e2540e
DIST restorecond-2.9-rc1.tar.gz 17747 BLAKE2B 0bcccb45b77bd97830f1e17e48c529f08d2e7eb1467f817ecc3520543e89d0f287c755baee53c27d0820d81a18cef34573b5f5e943b5c2d1e827886ce137f906 SHA512 6d0b0e3e36dfe567cf5349801078bc6ff9c6a7e7f2afc13f7ae775c9ae1d74fddfce14f3c83933f386e110ae5b4836c633d8307c9c4bce2000a3230bfcdb64eb
+DIST restorecond-2.9.tar.gz 18893 BLAKE2B fcdae1a4ec489f3f581212cdd3c13c5561feac3ee758f354dca75c97938c62b9ed04aedbd4b3b5cde09a5887247389262718145620d0b9749e364d1614f57241 SHA512 6de9dd4c6b8e5d8275221aba5df27437998f635cfe83a5da75de479e260ceea884a36253eb873a8d71e1a77ed67544d8657fb75fe409af1f630052ce73ec5d8a
diff --git a/sys-apps/restorecond/restorecond-2.9.ebuild b/sys-apps/restorecond/restorecond-2.9.ebuild
new file mode 100644
index 000000000000..b63423494d5c
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-2.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20190315"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/dbus-glib
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}