summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-04-27 02:08:38 +0800
committerJason Zaman <perfinion@gentoo.org>2017-04-27 02:14:17 +0800
commite23657020be7d689d84a7d1d1a7a82a7b0155773 (patch)
treeb4e3e1fce77e2691e38a51fe5b6fb9f52246e164 /sys-apps/restorecond
parentsys-apps/mcstrans: New Package split from policycoreutils (diff)
downloadgentoo-e23657020be7d689d84a7d1d1a7a82a7b0155773.tar.gz
gentoo-e23657020be7d689d84a7d1d1a7a82a7b0155773.tar.bz2
gentoo-e23657020be7d689d84a7d1d1a7a82a7b0155773.zip
sys-apps/restorecond: New Package split from policycoreutils
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/restorecond')
-rwxr-xr-xsys-apps/restorecond/files/restorecond.init30
-rw-r--r--sys-apps/restorecond/metadata.xml14
-rw-r--r--sys-apps/restorecond/restorecond-9999.ebuild57
3 files changed, 101 insertions, 0 deletions
diff --git a/sys-apps/restorecond/files/restorecond.init b/sys-apps/restorecond/files/restorecond.init
new file mode 100755
index 000000000000..709f1d1b9ece
--- /dev/null
+++ b/sys-apps/restorecond/files/restorecond.init
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 2006-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+is_selinux_enabled() {
+ local SE_ENABL="/usr/sbin/selinuxenabled"
+
+ if [ -x "$SE_ENABL" ]; then
+ $SE_ENABL && return 0 || return 1
+ else
+ ewarn "Restorecond: Unable to determine SELinux status"
+ return 1
+ fi
+}
+
+start() {
+ if is_selinux_enabled; then
+ ebegin "Starting restorecond"
+ start-stop-daemon --start --quiet --exec /usr/sbin/restorecond
+ eend $?
+ fi
+}
+
+stop() {
+ if is_selinux_enabled; then
+ ebegin "Stopping restorecond"
+ start-stop-daemon --stop --quiet --pidfile /var/run/restorecond.pid
+ eend $?
+ fi
+}
diff --git a/sys-apps/restorecond/metadata.xml b/sys-apps/restorecond/metadata.xml
new file mode 100644
index 000000000000..bad7d3fa425c
--- /dev/null
+++ b/sys-apps/restorecond/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>selinux@gentoo.org</email>
+ <name>SELinux Team</name>
+ </maintainer>
+ <longdescription>
+ daemon that watches for file creation and then sets the default SELinux file context
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SELinuxProject/selinux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/restorecond/restorecond-9999.ebuild b/sys-apps/restorecond/restorecond-9999.ebuild
new file mode 100644
index 000000000000..9195189cedce
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20161014"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}