summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-08 00:00:57 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-08 00:01:29 -0500
commit42fd644c5232e9847e12b27d6c10179871c56ebe (patch)
tree92892a3b1619b985fbe5cedd0b199e7cacbf465c /sys-apps/ripgrep/ripgrep-0.3.2.ebuild
parentdev-libs/ppl: version bump to 1.2 #601156 (diff)
downloadgentoo-42fd644c5232e9847e12b27d6c10179871c56ebe.tar.gz
gentoo-42fd644c5232e9847e12b27d6c10179871c56ebe.tar.bz2
gentoo-42fd644c5232e9847e12b27d6c10179871c56ebe.zip
sys-apps/ripgrep: version bump to 0.3.2
Diffstat (limited to 'sys-apps/ripgrep/ripgrep-0.3.2.ebuild')
-rw-r--r--sys-apps/ripgrep/ripgrep-0.3.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/ripgrep-0.3.2.ebuild b/sys-apps/ripgrep/ripgrep-0.3.2.ebuild
new file mode 100644
index 000000000000..8dd3de739331
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="a command line search tool that combines usability with raw speed"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/cargo
+ >=dev-lang/rust-1.11
+"
+
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
+src_compile() {
+ cargo build --release --verbose || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+ dodoc CHANGELOG.md README.md
+}