summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-06-30 21:32:26 +0200
committerSam James <sam@gentoo.org>2022-06-30 21:37:55 +0000
commit1c2778287f63f75b3ae19374de2d3a6b11e8f42c (patch)
treee4499b2732752d5d45f9967f44ab305514561aac /sys-apps/s6
parentdev-lang/execline: add 2.9.0.1 (diff)
downloadgentoo-1c2778287f63f75b3ae19374de2d3a6b11e8f42c.tar.gz
gentoo-1c2778287f63f75b3ae19374de2d3a6b11e8f42c.tar.bz2
gentoo-1c2778287f63f75b3ae19374de2d3a6b11e8f42c.zip
sys-apps/s6: add 2.11.1.2
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/26172 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.11.1.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index 6eaa14d7d718..7a5041c837b1 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1,2 +1,3 @@
DIST s6-2.11.1.0.tar.gz 228745 BLAKE2B 872ac1f736337a8e6617c46af92f8e894c06a4b40501ebf58568dc6a58cb594fdf36654cdb8cfd8e922431c17f9b4f82441296a3ce8031ba8b1f27fa1ba8a051 SHA512 ab3cb4a61fae21537eacffdaa427a0a6b23b12088586f0cd8dc993e0de29e9863d04c8706cb044acdc08254002b19eb5f894262d37348d467f8c713d8124e738
DIST s6-2.11.1.1.tar.gz 228878 BLAKE2B c94c18b66862c7945a317ab76d933d40fc360847b71c6fb3d507535ee41637d60327a05486a93ab7aec630a0c8ead61d6c17bfc064bd9f94b39a7cc56f76cb49 SHA512 f5fc903c11b57b2a83d9e120a51f64b63984a2af9b772dd6fd64f268b512a083350abedcae04c926deb6751b5ae30e992d6a4128ddf4ab1d49c548ef8f3d7752
+DIST s6-2.11.1.2.tar.gz 229092 BLAKE2B 672321d1b9b1b66e7c920a9c587d2ad3a3ca66be7bac0e3f9b4d8290c9d716a3e90ccaac709dbe7ac6525b972ef95429c776805fce3e36fc5b197e9cc826d258 SHA512 31feb2b1704d9561aff9fccdcb284e13f4ceb0f530214db8a393bdc10267801fbe1fc30b4271ad9bdf189dc52e2844f3db40f8f3e9cd438ac12415a51661f17d
diff --git a/sys-apps/s6/s6-2.11.1.2.ebuild b/sys-apps/s6/s6-2.11.1.2.ebuild
new file mode 100644
index 000000000000..dcdeeef35af5
--- /dev/null
+++ b/sys-apps/s6/s6-2.11.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+execline"
+
+RDEPEND="dev-libs/skalibs:=
+ execline? ( dev-lang/execline:= )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/execline
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ --disable-allstatic
+ --disable-static-libc
+ $(use_enable execline)
+ )
+
+ econf "${myconf[@]}"
+}