summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/salinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/salinfo')
-rw-r--r--sys-apps/salinfo/Manifest1
-rw-r--r--sys-apps/salinfo/files/salinfo-1.2-build.patch47
-rw-r--r--sys-apps/salinfo/metadata.xml5
-rw-r--r--sys-apps/salinfo/salinfo-1.2.ebuild29
4 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/salinfo/Manifest b/sys-apps/salinfo/Manifest
new file mode 100644
index 000000000000..b013aa5cb0d5
--- /dev/null
+++ b/sys-apps/salinfo/Manifest
@@ -0,0 +1 @@
+DIST salinfo-1.2.tar.gz 40511 SHA256 4c5b19a38d29b9e2883fc9f5ef3a5e9198c4a323b7cd1b35da21e86f392e1498 SHA512 6a92eb6ff38965a93ea61f034ba3607b871b7250cb640ced21b0eabaf94214ad2df78a3fb059fa0c61eb7aa90a6fc4e592ea852b89629b259c36d2b17fb7c4ca WHIRLPOOL d831aa5f773d51ff8170d6c102b211887e49bf24636f9f85dbc0154a393211fa3716f78b1b9e39013ce454336333ff184fbee28fbc047057dd31832fcb5eb236
diff --git a/sys-apps/salinfo/files/salinfo-1.2-build.patch b/sys-apps/salinfo/files/salinfo-1.2-build.patch
new file mode 100644
index 000000000000..848b363939af
--- /dev/null
+++ b/sys-apps/salinfo/files/salinfo-1.2-build.patch
@@ -0,0 +1,47 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,4 @@
++prefix = $(DESTDIR)
+ mandir := /usr/share/man
+ sbindir := /usr/sbin
+ logdir := /var/log/salinfo
+@@ -5,7 +6,7 @@ initdir := /etc/rc.d/init.d
+ sysconfigdir := /etc/sysconfig
+ logrotate := /etc/logrotate.d
+
+-CFLAGS += -Wall -g -O2 $(EXTRA_CFLAGS)
++CFLAGS += -Wall $(EXTRA_CFLAGS)
+ export CFLAGS
+
+ ifneq ($(VPATH),)
+--- a/sal.h
++++ b/sal.h
+@@ -27,6 +27,8 @@
+ * Keith Owens <kaos@sgi.com>
+ */
+
++#include <asm/fpu.h>
++
+ #include "efi.h"
+ #include "pal.h"
+
+--- a/salinfo_decode.c
++++ b/salinfo_decode.c
+@@ -303,7 +303,7 @@ log_dropped_records(void)
+ snprintf(line, sizeof(line), ", %d %s",
+ dropped_all[i]->dropped, dropped_all[i]->name);
+ dropped_all[i]->dropped = 0;
+- strncat(log, line, sizeof(log));
++ strncat(log, line, sizeof(log) - strlen(log));
+ }
+ }
+ syslog(LOG_NOTICE, "%s", log);
+@@ -424,7 +424,7 @@ talk_to_sal (void)
+ int fd;
+ char filename[PATH_MAX];
+ snprintf(filename, sizeof(filename), "%s/%s/.check", directory, rd[i]);
+- if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC)) < 0) {
++ if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC, 0644)) < 0) {
+ perror(filename);
+ goto out;
+ }
diff --git a/sys-apps/salinfo/metadata.xml b/sys-apps/salinfo/metadata.xml
new file mode 100644
index 000000000000..fe15722775f2
--- /dev/null
+++ b/sys-apps/salinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ia64</herd>
+</pkgmetadata>
diff --git a/sys-apps/salinfo/salinfo-1.2.ebuild b/sys-apps/salinfo/salinfo-1.2.ebuild
new file mode 100644
index 000000000000..2af829959d3b
--- /dev/null
+++ b/sys-apps/salinfo/salinfo-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="decode Itanium SAL records (e.g. various hardware errors)"
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/people/helgaas/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/etc/{rc.d,sysconfig} "${ED}"/var || die
+}