summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-10 21:15:52 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-10 21:20:11 +0100
commitae52a3b75f9e89df81735e7c37ca1c61f67170b7 (patch)
tree4d65d68b1ef548818be11833efa0d056554bdd44 /sys-apps/sandbox
parentsys-kernel/gentoo-kernel-bin: Bump to 5.11.13 (diff)
downloadgentoo-ae52a3b75f9e89df81735e7c37ca1c61f67170b7.tar.gz
gentoo-ae52a3b75f9e89df81735e7c37ca1c61f67170b7.tar.bz2
gentoo-ae52a3b75f9e89df81735e7c37ca1c61f67170b7.zip
sys-apps/sandbox: bump up to 2.23
One new change: - libsandbox: fix error handling of absolute_path() in check_syscall() Reported-by: Petr Zima Bug: https://bugs.gentoo.org/781824 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest1
-rw-r--r--sys-apps/sandbox/sandbox-2.23.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index b3b57e4be614..0db1586a1284 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,3 +1,4 @@
DIST sandbox-2.20.tar.xz 428400 BLAKE2B 11761631ce8e2e495adb41508f308bce875d416ec978e3eb3cb491d3d3a464d7653b8b81d4dcc7e5cd31e8a55069aafa263b85008651ee1d7318f32407fa4615 SHA512 06db36fc85bacf9a3a094c434b73277d8cdde986f2fad7676c42e8f84b3b8b653a1f4b1ec4af9fa1ff5484177419e18f5621275f56a8fbf3973ece524dd6d208
DIST sandbox-2.21.tar.xz 434540 BLAKE2B c9af3b44e65d96d20b98996a4b9e35cccf6b62020d49522b9fcf50b097d4ffe3719bb334405226c5ee650943bced365547a5d8b0f707ed26ef5f12a4d15dadba SHA512 42b85e230bc89d0e02f22a7ee81b4efbb2c37ff9db24982b4b39487664a095d384101b16a4689863bd32ea91349347980b1c7f8eecb09225bc65619829c6a5b2
DIST sandbox-2.22.tar.xz 437872 BLAKE2B 248920733ffcb56422bf02711f1ae69e81a176ffb59a1a45266bb81779e2916841eee0d237be4010062693604603893973f1fb295276c25a59654dc56a2593b4 SHA512 9c83e7748aad99e14d43ad81e6f3a8d818b821467023bbb3059ce8cee248090583d31500c1278705110f1b62cad5e5bf7f23390c6548095df709521c7d842eba
+DIST sandbox-2.23.tar.xz 437980 BLAKE2B fd417ea88512e7716a7f075442f684dc67b6c7d991e4375b47de4411353abd52764e5b85709aef06d175ba492b73edf5162c03e66e456cedb8586add18c8b5ea SHA512 d25b27bfeb5f5b9a331029a453be93947f32870b84d0e11efc5bb82044de6005111959a4efef87f1055e7065f76deccce6338d44bb7ab32e3a5ec053a429dbd5
diff --git a/sys-apps/sandbox/sandbox-2.23.ebuild b/sys-apps/sandbox/sandbox-2.23.ebuild
new file mode 100644
index 000000000000..844b1e1fe4cc
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ >=app-misc/pax-utils-0.1.19" #265376
+RDEPEND=""
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+multilib_src_configure() {
+ filter-lfs-flags #90228
+
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ # -j1 to prevent test faiures caused by file descriptor
+ # injection GNU make does.
+ emake -j1 check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_postinst() {
+ chown root:portage "${EROOT}"/var/log/sandbox
+ chmod 0770 "${EROOT}"/var/log/sandbox
+}