summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2016-03-13 19:57:05 +0100
committerSven Vermeulen <swift@gentoo.org>2016-03-13 20:46:40 +0100
commitce62bcdbb864d233c99a6e4c62eaa03692501434 (patch)
tree5c3324d2c280ea04ca69138c593b54591cca2316 /sys-apps/secilc/secilc-2.5.ebuild
parentsys-apps/policycoreutils: Bump to 2.5 release (diff)
downloadgentoo-ce62bcdbb864d233c99a6e4c62eaa03692501434.tar.gz
gentoo-ce62bcdbb864d233c99a6e4c62eaa03692501434.tar.bz2
gentoo-ce62bcdbb864d233c99a6e4c62eaa03692501434.zip
sys-apps/secilc: Bump to 2.5 release
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps/secilc/secilc-2.5.ebuild')
-rw-r--r--sys-apps/secilc/secilc-2.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/secilc/secilc-2.5.ebuild b/sys-apps/secilc/secilc-2.5.ebuild
new file mode 100644
index 000000000000..9b5d6dac018d
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20160223"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ epatch_user
+}