summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 21:26:06 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 21:57:46 -0700
commit2e7d5e63573f167f7d1c3ac232a7cf9054e5d90a (patch)
tree74b6db413c4e818bf929a4ba1c6caa56c7113b3d /sys-apps/secilc
parentsys-libs/libsepol: bump to 3.4_rc1 (diff)
downloadgentoo-2e7d5e63573f167f7d1c3ac232a7cf9054e5d90a.tar.gz
gentoo-2e7d5e63573f167f7d1c3ac232a7cf9054e5d90a.tar.bz2
gentoo-2e7d5e63573f167f7d1c3ac232a7cf9054e5d90a.zip
sys-apps/secilc: bump to 3.4_rc1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/secilc')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-3.4_rc1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index 323fe32e0e87..b71bbe80d191 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1 +1,2 @@
DIST secilc-3.3.tar.gz 181205 BLAKE2B ffccf2e6ea416f6e5a8270a488c6c6ed01b607af20fffed129f5d9b9957f2ab16e90a3fdbd57b597f1195987edf6a2ca1ae561cca62d176a01878fe24900f4b9 SHA512 11b2b6a56d588a71d8cc5b2e69e76579ddd3ea20e036bbfdbeefd8ed64a6dca3c8f963509a96231eb21807a195ec24e4807ef52dc2218ee0410ee0828ad77fa8
+DIST secilc-3.4-rc1.tar.gz 181269 BLAKE2B cc0bd0d6016833d64d615fe0f1ef59ab302b15238f10005412d3c2347056fbc5a0e587ac2e18f62f7cb1402a2749c117ac6b50e97df9677a0afc9b2270d9352d SHA512 d99e76c50395fcb20a4c08156b155f7411eab2ce3374899cc3cf6193d95ed3a5b2dae86d18ddfda838e6701aeddedbdb98f8faedeb4506ac5b19c7957763d22c
diff --git a/sys-apps/secilc/secilc-3.4_rc1.ebuild b/sys-apps/secilc/secilc-3.4_rc1.ebuild
new file mode 100644
index 000000000000..13b261011af0
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.4_rc1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+RDEPEND="${DEPEND}"
+BDEPEND="app-text/xmlto"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}