summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-06-10 16:19:55 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-06-10 16:20:26 +0900
commit43115ed54fa6291626dc263838c1d2bb1975b350 (patch)
tree9b9e2e3447b0f3322a7c55d6a6f5ef7749afe8f0 /sys-apps/sed
parentmedia-libs/libpng: Bump to version 1.6.23 (diff)
downloadgentoo-43115ed54fa6291626dc263838c1d2bb1975b350.tar.gz
gentoo-43115ed54fa6291626dc263838c1d2bb1975b350.tar.bz2
gentoo-43115ed54fa6291626dc263838c1d2bb1975b350.zip
sys-apps/sed: bump to EAPI=5 and support Prefix.
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/sed-4.2.2.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/sys-apps/sed/sed-4.2.2.ebuild b/sys-apps/sed/sed-4.2.2.ebuild
index f6a48783d4da..8e10644237a7 100644
--- a/sys-apps/sed/sed-4.2.2.ebuild
+++ b/sys-apps/sed/sed-4.2.2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
+
inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Super-useful stream editor"
@@ -31,24 +33,23 @@ src_bootstrap_sed() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
- # don't use sed here if we have to recover a broken host sed
-}
-src_compile() {
+ # don't use sed before bootstrap if we have to recover a broken host sed
src_bootstrap_sed
# this has to be after the bootstrap portion
sed -i \
-e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
doc/Makefile.in || die "sed html doc"
+}
- local myconf= bindir=/bin
- if ! use userland_GNU ; then
- myconf="--program-prefix=g"
- bindir=/usr/bin
+src_configure() {
+ local myconf=()
+ if use userland_GNU; then
+ myconf+=( --exec-prefix="${EPREFIX}" )
+ else
+ myconf+=( --program-prefix=g )
fi
# Should be able to drop this hack in next release. #333887
@@ -57,14 +58,7 @@ src_compile() {
export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
use static && append-ldflags -static
econf \
- --bindir=${bindir} \
$(use_enable acl) \
$(use_enable nls) \
- ${myconf}
- emake || die "build failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Install failed"
- dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
+ "${myconf[@]}"
}