summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-10-25 13:50:57 -0700
committerJason Zaman <perfinion@gentoo.org>2020-10-25 14:28:31 -0700
commit43fea86ba3d04a7993ec748924a4567b2af5f063 (patch)
tree0afbed95bbf3480e23f2381cf0e388b2b2346d73 /sys-apps/selinux-python
parentsys-process/audit: Add py3_8 (diff)
downloadgentoo-43fea86ba3d04a7993ec748924a4567b2af5f063.tar.gz
gentoo-43fea86ba3d04a7993ec748924a4567b2af5f063.tar.bz2
gentoo-43fea86ba3d04a7993ec748924a4567b2af5f063.zip
sys-apps/selinux-python: Add audit[python] dep
It was supposed to be optional in seobject.py but some places use it unconditionally Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/selinux-python-3.1-r1.ebuild95
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild1
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/selinux-python/selinux-python-3.1-r1.ebuild b/sys-apps/selinux-python/selinux-python-3.1-r1.ebuild
new file mode 100644
index 000000000000..e3fe4738a86b
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-3.1-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20200710"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+SEMNG_VER="${PV}"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
+ >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
+ >=sys-libs/libsepol-${SEPOL_VER}:=
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipy[${PYTHON_USEDEP}]
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index d890afd5e440..e3fe4738a86b 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -38,6 +38,7 @@ DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
>=sys-libs/libsepol-${SEPOL_VER}:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
dev-python/ipy[${PYTHON_USEDEP}]
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
${PYTHON_DEPS}"
RDEPEND="${DEPEND}"