summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-09 19:32:08 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-09 19:48:24 +0800
commit64a17ed29b721181c6ef67cf57036c8ef8efa1ea (patch)
treefc58271e37eded17a76b9447901d8c51ba51fda1 /sys-apps/semodule-utils
parentsys-apps/selinux-python: bump to 2.9_rc1 (diff)
downloadgentoo-64a17ed29b721181c6ef67cf57036c8ef8efa1ea.tar.gz
gentoo-64a17ed29b721181c6ef67cf57036c8ef8efa1ea.tar.bz2
gentoo-64a17ed29b721181c6ef67cf57036c8ef8efa1ea.zip
sys-apps/semodule-utils: bump to 2.9_rc1
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/semodule-utils')
-rw-r--r--sys-apps/semodule-utils/Manifest1
-rw-r--r--sys-apps/semodule-utils/semodule-utils-2.9_rc1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/Manifest b/sys-apps/semodule-utils/Manifest
index e186df70d989..81c8d1a4cff9 100644
--- a/sys-apps/semodule-utils/Manifest
+++ b/sys-apps/semodule-utils/Manifest
@@ -1,2 +1,3 @@
DIST semodule-utils-2.7.tar.gz 15447 BLAKE2B 44c28ad634ef2ab9e478edb58020547c217a01be0aa75cf3a2432be419efb626f0a5742ba1bcec50ba11c132c207a42c05836eb2749e1f80d4a8142fb9e34a9e SHA512 5c7c2a2224949f50c1119edba90d937363e22af52a38f06525e957b29f5310a3e3444d03980b2f808ce995de0f9fc0a9dca8b6167bbfde29c1a33b9bc786d3c8
DIST semodule-utils-2.8.tar.gz 12536 BLAKE2B 93a2f8fee887eba72b009071549a687fe86045344979e31493b3f17041ddf3f31c29ea3c754a31f6029847798dfe26d63b02fadc1042bc68aa414050b283d208 SHA512 13d79a22115f5448dafc5202dc3dec66b9ad826051d61d7c126defe823407959511db35713d97c7dfe9e79de96193fec91a10b98c13743e06a1213f5734f4ae7
+DIST semodule-utils-2.9-rc1.tar.gz 12548 BLAKE2B 62a4413f23ee8e30a9d60c00814425789362da4b056b03f5b27462534759d08f22c44b30a4d25c69bb5bd7447b5ed9e8cc89efb102e43c437adb4bf18f9a3540 SHA512 2e03dd8c23ad1b2f2492194ccd4a6fc39d4ee2d513778264b794011121c3b6eb896dab4a2236cf3934d1e200ad1f86ba6223bb6ac7aa81b1fd4c2a700dc7081a
diff --git a/sys-apps/semodule-utils/semodule-utils-2.9_rc1.ebuild b/sys-apps/semodule-utils/semodule-utils-2.9_rc1.ebuild
new file mode 100644
index 000000000000..2db179e63537
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-2.9_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20190125"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ install
+}