summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-29 14:18:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-03-30 09:02:34 +0200
commit258aabacb45aca606800e2bb8240240954426629 (patch)
tree98816992cfb972aeaf1f24805f69641b90521a75 /sys-apps/sg3_utils
parentnet-misc/openssh: stable 8.5_p1-r1 for hppa, bug #774090 (diff)
downloadgentoo-258aabacb45aca606800e2bb8240240954426629.tar.gz
gentoo-258aabacb45aca606800e2bb8240240954426629.tar.bz2
gentoo-258aabacb45aca606800e2bb8240240954426629.zip
sys-apps/sg3_utils: Bump to version 1.46
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/Manifest1
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.46.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index bbe164d06638..fb01d7cf889f 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1,3 +1,4 @@
DIST sg3_utils-1.42.tgz 1219231 BLAKE2B dd9ea2c324cb6f4c0ce770c90b7980da5e998bddc3a2be43a0aa9bea88dfe34291d0f58b393b2a5ac680c05dc673802ec9fae1ead37107bc49fa33bc7c4df503 SHA512 d16b65e36b2bccb4fc4c189f97e71fa38e6619f37d668a4ddd74a52c715fa62325288d9737812ed19c80547059dbd27be5a20565e27e1aabb571e8f5f8ac53ad
DIST sg3_utils-1.44.tar.xz 922152 BLAKE2B 8596ef78fbb7ade5a969f485b0f4ff63863dc8a5ff58fe630cffa91900ba9946b47ddf857346aa3904da8502afa4928f54baf99428344d2e561a90e52c8533ed SHA512 4f4d5536ebed62f2c81c55741043d9ac3f4610a4dd6ef2e3125f041afd57aae03a32c2affe84a960c9f61fb6f84784bc901c756a8c36c1bc97082fa61e73ae8d
DIST sg3_utils-1.45.tar.xz 989864 BLAKE2B 2d0a9e0edf514c8c7a566798f8087fc27d15d31cc8df39073dd97cff569da396b24236e0c231781625379b2ecefe7c99716d5d9c7dc104b15e150cb4e3c43e75 SHA512 fa25dedc447154d33937248a856af9a7ef380dda282a681d465a57d7dfc24b6c0409fa06aabf8cc28ba191e91db80fed0757b45212eddf713855574b48a97868
+DIST sg3_utils-1.46.tar.xz 1031972 BLAKE2B bf425b97247a5f5bae06a84d68066e2e2ec107a5c6d410f6d04a8879be22a07d5f5d0718674072458e654a4de3facb575522962beb2297a1fb4a7fe0df01b977 SHA512 576531da5022c5c2b3099bb28b3806a86d03594f572b8e72c5d451253e5b88761654027315749362b5037dd6108b691bd74566482b9c5078e3b1e5a2bb6e1a67
diff --git a/sys-apps/sg3_utils/sg3_utils-1.46.ebuild b/sys-apps/sg3_utils/sg3_utils-1.46.ebuild
new file mode 100644
index 000000000000..12b5589c956b
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.46.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="!sys-apps/rescan-scsi-bus"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26-stdint.patch #580236
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}