summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-10-21 18:05:18 +0200
committerPacho Ramos <pacho@gentoo.org>2017-10-21 18:05:18 +0200
commit764da46ea3be96834c9cbd1637ab1277c90d0df8 (patch)
tree140f7d65fcb4c834482c05814caffe8a5fdf9581 /sys-apps/systemd-readahead
parentapp-misc/carbon-c-relay: version bump to v3.2 (diff)
downloadgentoo-764da46ea3be96834c9cbd1637ab1277c90d0df8.tar.gz
gentoo-764da46ea3be96834c9cbd1637ab1277c90d0df8.tar.bz2
gentoo-764da46ea3be96834c9cbd1637ab1277c90d0df8.zip
sys-apps/systemd-readahead: Backport fixes to append <sys/sysmacros.h> includes where needed (#604614)
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sys-apps/systemd-readahead')
-rw-r--r--sys-apps/systemd-readahead/files/systemd-readahead-216-sysmacros.patch61
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild13
2 files changed, 71 insertions, 3 deletions
diff --git a/sys-apps/systemd-readahead/files/systemd-readahead-216-sysmacros.patch b/sys-apps/systemd-readahead/files/systemd-readahead-216-sysmacros.patch
new file mode 100644
index 000000000000..61cda995af4b
--- /dev/null
+++ b/sys-apps/systemd-readahead/files/systemd-readahead-216-sysmacros.patch
@@ -0,0 +1,61 @@
+Backported to 216 adapting headers locations
+
+From 27d13af71c3af6b2f9b60556d2c046dbb6e36e23 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 14 Mar 2016 17:44:49 -0400
+Subject: [PATCH] include sys/sysmacros.h in more places
+
+Since glibc is moving away from implicitly including sys/sysmacros.h
+all the time via sys/types.h, include the header directly in more
+places. This seems to cover most makedev/major/minor usage.
+---
+ src/shared/macro.h | 1 +
+ src/shared/util.h | 1 +
+ src/libudev/libudev.h | 1 +
+ src/udev/udev.h | 1 +
+ 5 files changed, 5 insertions(+)
+
+diff --git a/src/shared/macro.h b/src/shared/macro.h
+index c34441d75d..b36a95675a 100644
+--- a/src/shared/macro.h
++++ b/src/shared/macro.h
+@@ -23,6 +23,7 @@
+ #include <inttypes.h>
+ #include <stdbool.h>
+ #include <sys/param.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #define _printf_(a,b) __attribute__ ((format (printf, a, b)))
+diff --git a/src/libudev/libudev.h b/src/libudev/libudev.h
+index eb58740d26..3f6d0ed16c 100644
+--- a/src/libudev/libudev.h
++++ b/src/libudev/libudev.h
+@@ -21,6 +21,7 @@
+ #define _LIBUDEV_H_
+
+ #include <stdarg.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #ifdef __cplusplus
+--- a/src/shared/util.h~ 2014-08-19 16:47:52.000000000 +0200
++++ b/src/shared/util.h 2017-10-21 17:58:54.294946349 +0200
+@@ -35,6 +35,7 @@
+ #include <limits.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <dirent.h>
+ #include <sys/resource.h>
+ #include <stddef.h>
+--- a/src/udev/udev.h~ 2014-07-29 19:51:00.000000000 +0200
++++ b/src/udev/udev.h 2017-10-21 17:59:50.026412561 +0200
+@@ -20,6 +20,7 @@
+
+ #include <sys/types.h>
+ #include <sys/param.h>
++#include <sys/sysmacros.h>
+ #include <signal.h>
+
+ #include "macro.h"
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
index e29293a0a6cc..e256882d9165 100644
--- a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit systemd toolchain-funcs udev
DESCRIPTION="Split of readahead systemd implementation"
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE=""
-S=${WORKDIR}/systemd-${PV}
+S="${WORKDIR}/systemd-${PV}"
RDEPEND=">=sys-apps/systemd-217:="
DEPEND="${RDEPEND}
@@ -26,7 +26,14 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ # https://github.com/systemd/systemd/pull/2838 , bug #604614
+ "${FILESDIR}/${P}-sysmacros.patch"
+)
+
src_prepare() {
+ default
+
# systemd-notify no longer supports readahead playing
sed -i -e 's:ExecStart=@SYSTEMD_NOTIFY@ --readahead=done:ExecStart=/bin/touch /run/systemd/readahead/done:' \
units/systemd-readahead-done.service.in || die