summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-18 13:21:44 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-18 13:22:15 -0500
commit8741d5b7248b5bbf82eaebceabc1bb79f308a5c4 (patch)
tree7cf3ed7698d0e4c2417bba6a1a48cd1b60a406b3 /sys-apps/systemd/systemd-9999.ebuild
parentapp-emulation/runc: 1.0.0_rc2-r1 revbump to add commit to version output (diff)
downloadgentoo-8741d5b7248b5bbf82eaebceabc1bb79f308a5c4.tar.gz
gentoo-8741d5b7248b5bbf82eaebceabc1bb79f308a5c4.tar.bz2
gentoo-8741d5b7248b5bbf82eaebceabc1bb79f308a5c4.zip
sys-apps/systemd: make the ebuild compiler-agnostic
Remove binutils and gcc from depend. Remove gcc version check. Pass --with-efi-libdir to workaround compilers which do not support the -print-multi-os-directory option. Note that gnu-efi headers still require gcc; EFI_CC can be set to gcc to work around this. Bug: https://bugs.gentoo.org/599210 Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild13
1 files changed, 1 insertions, 12 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index a45086f14ee9..028d6865ad81 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -86,8 +86,6 @@ DEPEND="${COMMON_DEPEND}
dev-util/gperf
>=dev-util/intltool-0.50
>=sys-apps/coreutils-8.16
- >=sys-devel/binutils-2.23.1
- >=sys-devel/gcc-4.6
>=sys-kernel/linux-headers-${MINKV}
virtual/pkgconfig
gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
@@ -124,16 +122,6 @@ pkg_pretend() {
fi
fi
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4
- || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
- then
- eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
- eerror "gcc version using gcc-config."
- die "systemd requires at least gcc 4.6"
- fi
- fi
-
if [[ ${MERGE_TYPE} != buildonly ]]; then
if kernel_is -lt ${MINKV//./ }; then
ewarn "Kernel version at least ${MINKV} required"
@@ -231,6 +219,7 @@ multilib_src_configure() {
$(multilib_native_use_enable elfutils)
$(use_enable gcrypt)
$(multilib_native_use_enable gnuefi)
+ --with-efi-libdir="/usr/$(get_libdir)"
$(multilib_native_use_enable http microhttpd)
$(usex http $(multilib_native_use_enable ssl gnutls) --disable-gnutls)
$(multilib_native_use_enable idn libidn)