summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-03-05 12:18:41 -0500
committerMike Gilbert <floppym@gentoo.org>2016-03-05 13:10:59 -0500
commit9258b81a69cdc1fb0f3eb227a616b1a6798ee102 (patch)
tree61504fbd18645932d797b1b1ce6279fd54e8aa6f /sys-apps/systemd/systemd-9999.ebuild
parentsys-apps/openrc: ia64/sparc stable wrt bug #571696 (diff)
downloadgentoo-9258b81a69cdc1fb0f3eb227a616b1a6798ee102.tar.gz
gentoo-9258b81a69cdc1fb0f3eb227a616b1a6798ee102.tar.bz2
gentoo-9258b81a69cdc1fb0f3eb227a616b1a6798ee102.zip
sys-apps/systemd: Move to EAPI 6
Package-Manager: portage-2.2.27_p64
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index df82d8e5e7f1..2213ad1e4097 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
@@ -12,7 +12,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
-inherit autotools bash-completion-r1 linux-info multilib \
+inherit autotools bash-completion-r1 linux-info \
multilib-minimal pam systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
@@ -144,9 +144,15 @@ src_unpack() {
src_prepare() {
# Bug 463376
sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
- epatch "${FILESDIR}/218-Dont-enable-audit-by-default.patch"
- epatch "${FILESDIR}/228-noclean-tmp.patch"
- epatch_user
+
+ local PATCHES=(
+ "${FILESDIR}/218-Dont-enable-audit-by-default.patch"
+ "${FILESDIR}/228-noclean-tmp.patch"
+ )
+ [[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )
+
+ default
+
eautoreconf
}