summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-06-20 12:27:45 -0400
committerMike Gilbert <floppym@gentoo.org>2021-06-20 13:18:48 -0400
commit61b3d2ebb4de957a0cc8cd08795f3547834b9f1e (patch)
treece308f1121ad9f965c3febb3d90d9c5ee928aaf2 /sys-apps/systemd
parentsys-apps/hwids: call systemd-hwdb when USE=systemd is enabled (diff)
downloadgentoo-61b3d2ebb4de957a0cc8cd08795f3547834b9f1e.tar.gz
gentoo-61b3d2ebb4de957a0cc8cd08795f3547834b9f1e.tar.bz2
gentoo-61b3d2ebb4de957a0cc8cd08795f3547834b9f1e.zip
sys-apps/systemd: call systemd-hwdb update
... instead of udevadm hwdb --update Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 8dd85417f98c..3f2168e521b6 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -132,7 +132,7 @@ RDEPEND="${COMMON_DEPEND}
# sys-apps/dbus: the daemon only (+ build-time lib dep for tests)
PDEPEND=">=sys-apps/dbus-1.9.8[systemd]
- hwdb? ( >=sys-apps/hwids-20150417[udev] )
+ hwdb? ( sys-apps/hwids[systemd(+),udev] )
>=sys-fs/udev-init-scripts-34
policykit? ( sys-auth/polkit )
!vanilla? ( sys-apps/gentoo-systemd-integration )"
@@ -459,9 +459,9 @@ pkg_postinst() {
systemd_update_catalog
# Keep this here in case the database format changes so it gets updated
- # when required. Despite that this file is owned by sys-apps/hwids.
- if has_version "sys-apps/hwids[udev]"; then
- udevadm hwdb --update --root="${EROOT}"
+ # when required.
+ if use hwdb; then
+ systemd-hwdb --root="${ROOT}" update
fi
udev_reload || FAIL=1