summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-07-06 10:01:41 -0400
committerMike Gilbert <floppym@gentoo.org>2020-07-06 10:05:24 -0400
commitcb42fec761f69750bed2e7494fda976a315dc8e9 (patch)
tree9ce3f8e3a6534d5e7d8eb5764c96e7ad27783fef /sys-apps/systemd
parentnet-wireless/iwd: transfer keywords to 1.7-r1 for CONFIG_CHECK fix (diff)
downloadgentoo-cb42fec761f69750bed2e7494fda976a315dc8e9.tar.gz
gentoo-cb42fec761f69750bed2e7494fda976a315dc8e9.tar.bz2
gentoo-cb42fec761f69750bed2e7494fda976a315dc8e9.zip
sys-apps/systemd: fix build with libmicrohttpd-0.9.71
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/files/245-libmicrohttpd-0.9.71.patch67
-rw-r--r--sys-apps/systemd/systemd-245.5.ebuild1
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/systemd/files/245-libmicrohttpd-0.9.71.patch b/sys-apps/systemd/files/245-libmicrohttpd-0.9.71.patch
new file mode 100644
index 000000000000..08affa501700
--- /dev/null
+++ b/sys-apps/systemd/files/245-libmicrohttpd-0.9.71.patch
@@ -0,0 +1,67 @@
+From d17eabb1052e7c8c432331a7a782845e36164f01 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Tue, 30 Jun 2020 09:56:10 +0200
+Subject: [PATCH] =?UTF-8?q?Fix=20build=20with=20=C2=B5httpd=200.9.71?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The return type of callbacks was changed from int to an enum.
+---
+ src/journal-remote/journal-gatewayd.c | 4 ++--
+ src/journal-remote/journal-remote-main.c | 2 +-
+ src/journal-remote/microhttpd-util.h | 6 ++++++
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/src/journal-remote/journal-gatewayd.c b/src/journal-remote/journal-gatewayd.c
+index 5177e0d1577..3ab7c98b0b5 100644
+--- a/src/journal-remote/journal-gatewayd.c
++++ b/src/journal-remote/journal-gatewayd.c
+@@ -349,7 +349,7 @@ static int request_parse_range(
+ return 0;
+ }
+
+-static int request_parse_arguments_iterator(
++static mhd_result request_parse_arguments_iterator(
+ void *cls,
+ enum MHD_ValueKind kind,
+ const char *key,
+@@ -796,7 +796,7 @@ static int request_handler_machine(
+ return MHD_queue_response(connection, MHD_HTTP_OK, response);
+ }
+
+-static int request_handler(
++static mhd_result request_handler(
+ void *cls,
+ struct MHD_Connection *connection,
+ const char *url,
+diff --git a/src/journal-remote/journal-remote-main.c b/src/journal-remote/journal-remote-main.c
+index 69a111afead..f82d188a8c6 100644
+--- a/src/journal-remote/journal-remote-main.c
++++ b/src/journal-remote/journal-remote-main.c
+@@ -253,7 +253,7 @@ static int process_http_upload(
+ return mhd_respond(connection, MHD_HTTP_ACCEPTED, "OK.");
+ };
+
+-static int request_handler(
++static mhd_result request_handler(
+ void *cls,
+ struct MHD_Connection *connection,
+ const char *url,
+diff --git a/src/journal-remote/microhttpd-util.h b/src/journal-remote/microhttpd-util.h
+index d90c6bbd4f1..4ca9a5c4f16 100644
+--- a/src/journal-remote/microhttpd-util.h
++++ b/src/journal-remote/microhttpd-util.h
+@@ -47,6 +47,12 @@
+ # define MHD_create_response_from_fd_at_offset64 MHD_create_response_from_fd_at_offset
+ #endif
+
++#if MHD_VERSION >= 0x00097002
++# define mhd_result enum MHD_Result
++#else
++# define mhd_result int
++#endif
++
+ void microhttpd_logger(void *arg, const char *fmt, va_list ap) _printf_(2, 0);
+
+ /* respond_oom() must be usable with return, hence this form. */
diff --git a/sys-apps/systemd/systemd-245.5.ebuild b/sys-apps/systemd/systemd-245.5.ebuild
index 7ae8a3de58d6..88016e667693 100644
--- a/sys-apps/systemd/systemd-245.5.ebuild
+++ b/sys-apps/systemd/systemd-245.5.ebuild
@@ -201,6 +201,7 @@ src_prepare() {
# Add local patches here
PATCHES+=(
+ "${FILESDIR}/245-libmicrohttpd-0.9.71.patch"
)
if ! use vanilla; then