summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-09-07 23:57:49 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-27 08:39:03 +0200
commitd4d5c234425a7e76f526c90acfbdc9c1b1770140 (patch)
tree2dd5caaed2f9c0705b11b12c19f39f6ff9883663 /sys-apps/tas
parentdev-ruby/sinatra: add 2.0.4 (diff)
downloadgentoo-d4d5c234425a7e76f526c90acfbdc9c1b1770140.tar.gz
gentoo-d4d5c234425a7e76f526c90acfbdc9c1b1770140.tar.bz2
gentoo-d4d5c234425a7e76f526c90acfbdc9c1b1770140.zip
sys-apps/tas: New package
Closes: https://bugs.gentoo.org/665468 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9804
Diffstat (limited to 'sys-apps/tas')
-rw-r--r--sys-apps/tas/Manifest1
-rw-r--r--sys-apps/tas/files/tas.ini8
-rw-r--r--sys-apps/tas/files/tas.initd17
-rw-r--r--sys-apps/tas/files/tas.service11
-rw-r--r--sys-apps/tas/metadata.xml25
-rw-r--r--sys-apps/tas/tas-1.5.2.180622.ebuild73
6 files changed, 135 insertions, 0 deletions
diff --git a/sys-apps/tas/Manifest b/sys-apps/tas/Manifest
new file mode 100644
index 000000000000..986717cf47b6
--- /dev/null
+++ b/sys-apps/tas/Manifest
@@ -0,0 +1 @@
+DIST TAS_1.5.2_build.180622.zip 12434740 BLAKE2B 9017aee7512b6d467d2922dc9db3f3cc58046beb4f48838748ac806da1c0c84f99984e2b29867a36db4bcb58a90f3e23c29dbfd8d73e1049cac4bf82ac88d021 SHA512 166483fe514f09c2fbfd27a05072f0bfa0d2cc8f92428451e055ddd9fbc24dfa3e912de224775d16dbb8880391c79ddc2ee9ff55c1e31e0fcf2daa3b05eb7d60
diff --git a/sys-apps/tas/files/tas.ini b/sys-apps/tas/files/tas.ini
new file mode 100644
index 000000000000..06f125000bbd
--- /dev/null
+++ b/sys-apps/tas/files/tas.ini
@@ -0,0 +1,8 @@
+Config :
+{
+ updateFreq = 10;
+};
+Path :
+{
+ installedPath = "/etc/supermicro";
+};
diff --git a/sys-apps/tas/files/tas.initd b/sys-apps/tas/files/tas.initd
new file mode 100644
index 000000000000..21b9bd14b0d5
--- /dev/null
+++ b/sys-apps/tas/files/tas.initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+name="Supermicro Thin-Agent Service"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+command="/usr/bin/IPMITAS"
+command_args="-agent start-service"
+command_args_stop="-agent stop-service"
+start_stop_daemon_args="--env LC_ALL=C"
+
+stop() {
+ ebegin "Stopping ${name}"
+ ${command} ${command_args_stop}
+ eend $?
+}
diff --git a/sys-apps/tas/files/tas.service b/sys-apps/tas/files/tas.service
new file mode 100644
index 000000000000..7bf6db6265ee
--- /dev/null
+++ b/sys-apps/tas/files/tas.service
@@ -0,0 +1,11 @@
+[Unit]
+After=network-online.target
+Description=TAS
+
+[Service]
+Environment="LC_ALL=C"
+ExecStart=/usr/bin/IPMITAS
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/tas/metadata.xml b/sys-apps/tas/metadata.xml
new file mode 100644
index 000000000000..51cf888b9566
--- /dev/null
+++ b/sys-apps/tas/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ TAS provides server usage information at the OS level,
+ that users could monitor on a system through the BMC/IPMI.
+ For HW Platforms, where there is not RAID controller in configuration,
+ it is recommended to install TAS.
+ Provides Asset and Health Information:
+ Hardware Information:
+ CPU, Memory, NIC, and HDD Health
+ Usage Monitoring: CPU workload, Memory Size, NIC State, and Disk Partition
+ Supports RAID and HDD SMART Failure Information:
+ Broadcom 3108 RAID Controller and Intel PCH/RSTe RAID Chipset
+ Generates State Event Log: Disk Failure and NIC State Change
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/tas/tas-1.5.2.180622.ebuild b/sys-apps/tas/tas-1.5.2.180622.ebuild
new file mode 100644
index 000000000000..182dd6d61afb
--- /dev/null
+++ b/sys-apps/tas/tas-1.5.2.180622.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eapi7-ver linux-info systemd
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN^^}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Supermicro Thin-Agent Service for monitoring through the BMC/IPMI"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_build.${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="BSD supermicro"
+SLOT="0"
+
+RDEPEND="net-misc/networkmanager
+ sys-apps/ethtool
+ sys-apps/net-tools
+ sys-apps/smartmontools
+ sys-block/storcli
+ sys-devel/bc
+ sys-fs/lsscsi
+ sys-fs/mdadm"
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/bin/IPMITAS"
+
+DOCS=(
+ "clireadme.txt"
+ "ReleaseNotes.txt"
+ "software_license_agreement_pv.pdf"
+ "TAS_UserGuide.pdf"
+)
+
+CONFIG_CHECK="~IPMI_DEVICE_INTERFACE ~IPMI_HANDLER ~IPMI_SI"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=TAS"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack "${S}"/${MY_PN}_${MY_PV}_build.${MY_DATE}_Linux.tar.gz
+}
+
+src_install() {
+ dobin $(usex amd64 '64' '32')bit/IPMITAS
+
+ insinto /etc/supermicro
+ doins "${FILESDIR}"/tas.ini
+
+ dodir /var/log/tas
+ local logfiles=( {starttime,tas,tas.com}.log )
+ for logfile in ${logfiles[@]}; do
+ touch "${ED%/}"/var/log/tas/${logfile} || die
+ dosym ../../var/log/tas/${logfile} /etc/supermicro/${logfile}
+ done
+
+ newinitd "${FILESDIR}"/tas.initd tas
+ systemd_newunit "${FILESDIR}"/tas.service tas.service
+
+ einstalldocs
+}