summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-07 14:36:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-07 15:45:40 +0100
commit43de9a271b3b08b20c3c3414326da3f61390eb49 (patch)
treec72ead38effa14f1276386c5fdb6338a09e45f14 /sys-apps/texinfo/texinfo-6.1.ebuild
parentdev-python/alembic: return of vn -0.7.4 to fix breakage (diff)
downloadgentoo-43de9a271b3b08b20c3c3414326da3f61390eb49.tar.gz
gentoo-43de9a271b3b08b20c3c3414326da3f61390eb49.tar.bz2
gentoo-43de9a271b3b08b20c3c3414326da3f61390eb49.zip
sys-apps/texinfo: Bump to version 6.1
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/texinfo/texinfo-6.1.ebuild')
-rw-r--r--sys-apps/texinfo/texinfo-6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/texinfo/texinfo-6.1.ebuild b/sys-apps/texinfo/texinfo-6.1.ebuild
new file mode 100644
index 000000000000..17ee03ba91fc
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI="5"
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ dev-lang/perl
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --with-external-libintl-perl \
+ --with-external-Unicode-EastAsianWidth \
+ --with-external-Text-Unidecode \
+ $(use_enable nls)
+}