summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-13 17:12:13 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-13 17:12:30 +0200
commit0475c8dcfd3e4b727d3125e75c577f5aad27f9c0 (patch)
treea2648ddb048a08364d8759c312a9b02a5c4f593a /sys-apps/texinfo
parentnet-analyzer/openbsd-netcat: marked ~ppc64 (diff)
downloadgentoo-0475c8dcfd3e4b727d3125e75c577f5aad27f9c0.tar.gz
gentoo-0475c8dcfd3e4b727d3125e75c577f5aad27f9c0.tar.bz2
gentoo-0475c8dcfd3e4b727d3125e75c577f5aad27f9c0.zip
sys-apps/texinfo: Bump to version 6.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-6.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 26eb871ad851..3a58debd9213 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -2,3 +2,4 @@ DIST texinfo-4.13.tar.lzma 1563777 SHA256 6d28b0ceae866e3536142fc552e7a3bc9f84c8
DIST texinfo-6.1.tar.xz 4520376 SHA256 ac68394ce21b2420ba7ed7cec65d84aacf308cc88e9bf4716fcfff88286883d2 SHA512 ae47295f3bcfb728c3be59421cf830ecfa5fc7856a086e45da2bac89600d883aa4406a6ef62d7ee5dc2bab83a3efa1cec861a3b4b14b85bbecb53ebf3ebf7235 WHIRLPOOL 187f11681f041aa5f4260c6c2833cb877a4c74afda73d4f72008c61c8a089dd0393ff90257410d5e48b9501c36dd4991032db001c5c17b8224afb6f5819cd165
DIST texinfo-6.3.tar.xz 4468048 SHA256 246cf3ffa54985118ec2eea2b8d0c71b92114efe6282c2ae90d65029db4cf93a SHA512 ef6c5878d9db497d7963bd9138418b30c39a5605c215bf2f4e8f1f083d93c3c99f8c459aa675f7da3b78da6189cb6bbf3cf19a2ee1d52e569de2f6ce82762bf4 WHIRLPOOL 45cb684cd14fdfc5da1ec54cee017e0835334481df9f4db35c18b2837509b1d15ea590d90a925edf4febae59669e9dc8e6287838368e8730f714811e70dbd417
DIST texinfo-6.4.tar.xz 4497624 SHA256 6ae2e61d87c6310f9af7c6f2426bd0470f251d1a6deb61fba83a3b3baff32c3a SHA512 628e7fb64c4cb6d4ec879d5593e3660dbbbf41915c7aec68b6af209a1c496bee8a3879a69e4e047c3bee0cb476540ffd6ebdef5ec7b712edd191a82ce9ac4006 WHIRLPOOL 7cc7c955b4ef85ca72436668305bb9db0b0d09feb9953e4bdb812f2f1124957cfd59f16b01876f7d93e145692874f1902fb1d850e7ad8daae668ab8747a8e6fa
+DIST texinfo-6.5.tar.xz 4503048 SHA256 77774b3f4a06c20705cc2ef1c804864422e3cf95235e965b1f00a46df7da5f62 SHA512 06831b4c74a1ba7a9cff937069e40ab26db1204aa8761d63254651ffacf6b0cb95d7078ba1cc59d95427239ab7e4f4aedf582967854281bfea3850b1ed5b1fdc WHIRLPOOL f8d374c5279eb5d463192391875ed663ed2fa33e653a11d7304595549243cd68988b9f7f1e4b13ef61d2efa906344868c889293514b7b875b66a954a16466919
diff --git a/sys-apps/texinfo/texinfo-6.5.ebuild b/sys-apps/texinfo/texinfo-6.5.ebuild
new file mode 100644
index 000000000000..6e53f592081e
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}