summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-06-19 00:35:50 -0400
committerTim Harder <radhermit@gentoo.org>2016-06-19 00:36:51 -0400
commit64d14b7c86d4d4e3815be236ce48b8c12dfa6a41 (patch)
tree20451546679c7917d4547c9d5dc347d2357146ab /sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild
parentapp-misc/dateutils: remove old (diff)
downloadgentoo-64d14b7c86d4d4e3815be236ce48b8c12dfa6a41.tar.gz
gentoo-64d14b7c86d4d4e3815be236ce48b8c12dfa6a41.tar.bz2
gentoo-64d14b7c86d4d4e3815be236ce48b8c12dfa6a41.zip
sys-apps/the_silver_searcher: version bump to 0.32.0
Diffstat (limited to 'sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild')
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild
new file mode 100644
index 000000000000..eb64cc5f2000
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.32.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="https://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}