summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEwoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>2020-01-04 18:40:09 +0100
committerYixun Lan <dlan@gentoo.org>2020-01-22 14:34:17 +0800
commit208e6cae7a28c505808777b7d0546aa7a93d9d9a (patch)
treebbb2bfc1271d53324785f5e5febbba2fdc97c1cf /sys-apps/tuned
parentdev-python/python-linux-procfs: Add version 0.6.1 (diff)
downloadgentoo-208e6cae7a28c505808777b7d0546aa7a93d9d9a.tar.gz
gentoo-208e6cae7a28c505808777b7d0546aa7a93d9d9a.tar.bz2
gentoo-208e6cae7a28c505808777b7d0546aa7a93d9d9a.zip
sys-apps/tuned: Add 2.13.0
* Move from Python 2 to Python 3. * Correct DOCDIR patching * Optimize Python files * Update XDG icon cache Closes: https://bugs.gentoo.org/704760 Closes: https://github.com/gentoo/gentoo/pull/14248 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Ewoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-apps/tuned')
-rw-r--r--sys-apps/tuned/Manifest1
-rw-r--r--sys-apps/tuned/tuned-2.13.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index 1b78512c74ad..48a49f8969e3 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1,3 +1,4 @@
DIST tuned-2.10.0.tar.gz 160254 BLAKE2B 0a09b4b870ec153adc62de7811af561ddb3967d459b1d5e8b6f02c5ac036ed170ad3368d18fc1b3fd40649335035cce971a54e1eda8745c77e836a3b2d892a83 SHA512 e0674533f17ac27cd3647808cda1f51d9905f563521af8cb3ffd1854098d6e2ca1adac82e542e6bdf86cce7e659303464eac50b8823167360783a75843d02a60
+DIST tuned-2.13.0.tar.gz 193816 BLAKE2B 1e51a9da855f54db9ac8ed6e764c091d513c1101771422a62c7c501dc3c8741430eb3503803b408709868d16d4791fbedb9dbc088b36fb693f065a1b6054fa15 SHA512 d81b0a80f911fe808ca324319da3e42c3c15196c0c37343d33b45c2b34f33e205e2913d77ffda8598379a91ef72ab73d88d7b83a4684b6a067e3f36d98a85927
DIST tuned-2.7.0.tar.bz2 107541 BLAKE2B b26924a091fd78bbc7e61c8a45b49808d132eb5ebd3fdc00f96be7eaddcffd88183fa59595a29e2c402b2c434bfdb706601d397c2ebca9a5822c6a3416373465 SHA512 ce09dd854e89762fa376f7f63a59feb384940b5dbc5ad74370b33bbda3f060f09e79d2988de3535b072ad749ab7be43ccaaa46a343a9df50eec6c40d7ab85d55
DIST tuned-2.7.1.tar.bz2 107471 BLAKE2B c9259ee5ce502100edc7c537f6857de3a6af4af0be1773e0c9422c10de16b4a513d514532da26764b0a743f943577d527919f329ff48a012e269fd2a0ac59f10 SHA512 4a4785e3d20ed7f1c2969066676f5fa3d8286b500de1c63169d745e701e1410092d29429d25c13c3515d37ef73dd297945d69db176d693d4152bfbe9ba626833
diff --git a/sys-apps/tuned/tuned-2.13.0.ebuild b/sys-apps/tuned/tuned-2.13.0.ebuild
new file mode 100644
index 000000000000..fe231367c6c7
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.13.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://github.com/redhat-performance/tuned"
+SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-linux-procfs[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ ${DEPEND}
+ sys-apps/dbus
+ sys-apps/ethtool
+ sys-power/powertop
+ dev-util/systemtap"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
+ Makefile || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ python_fix_shebang "${D}"
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}