summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-07-26 14:23:00 +0800
committerYixun Lan <dlan@gentoo.org>2016-07-26 14:23:00 +0800
commitcdaadf65e31a8b72908898fd9ee1da7108fdcc42 (patch)
treeb098bf6d287c216fad65584d5ee3803987baca43 /sys-apps/tuned
parentsys-process/criu: version bump 2.4 (diff)
downloadgentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.tar.gz
gentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.tar.bz2
gentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.zip
sys-apps/tuned: version bump 2.7.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/tuned')
-rw-r--r--sys-apps/tuned/Manifest1
-rw-r--r--sys-apps/tuned/files/tuned-2.7.0-upstream.patch39
-rw-r--r--sys-apps/tuned/tuned-2.7.0.ebuild50
3 files changed, 90 insertions, 0 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index 240ac2f2d983..a59333d73cfe 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1 +1,2 @@
DIST tuned-2.6.0.tar.bz2 98362 SHA256 945c785b8020960d2665b570b3168c366e6b82399801952aea54b4d178dac876 SHA512 da818cb6c04e10d97b7eb52fb37500128ca5b37c79428d1b84578d4147507a210052c395f523f91907a112e282a47f9a5d4745fe2960471f42d5d09f87a3c57d WHIRLPOOL 23457c5e161675f90326060d485626f2d176e6c42b34f21fceecf7299c21607b8537ff741742015c0045c8150ce379a7274b11da547581e18bea97671c1b4045
+DIST tuned-2.7.0.tar.bz2 107541 SHA256 8f50718264690732504486a65931d7ef558d4d43da9a86bc6f5c6855e3a7e448 SHA512 ce09dd854e89762fa376f7f63a59feb384940b5dbc5ad74370b33bbda3f060f09e79d2988de3535b072ad749ab7be43ccaaa46a343a9df50eec6c40d7ab85d55 WHIRLPOOL 272e77e429097f9c14beb31f5d911762837008a0e8affeb9abbcaf03172edd8296064b1926ff56f0c1272a9a51d88cf9044ee4b45676844cb249d5be1865983c
diff --git a/sys-apps/tuned/files/tuned-2.7.0-upstream.patch b/sys-apps/tuned/files/tuned-2.7.0-upstream.patch
new file mode 100644
index 000000000000..f864433b1941
--- /dev/null
+++ b/sys-apps/tuned/files/tuned-2.7.0-upstream.patch
@@ -0,0 +1,39 @@
+diff --git a/tuned-gui.py b/tuned-gui.py
+index 0555404..b169dec 100755
+--- a/tuned-gui.py
++++ b/tuned-gui.py
+@@ -89,7 +89,7 @@ class Base(object):
+ try:
+ self.controller = \
+ tuned.admin.DBusController(consts.DBUS_BUS,
+- consts.DBUS_OBJECT, consts.DBUS_INTERFACE)
++ consts.DBUS_INTERFACE, consts.DBUS_OBJECT)
+ self.controller.is_running()
+ except tuned.admin.exceptions.TunedAdminDBusException, ex:
+ response = self.tuned_daemon_exception_dialog.run()
+diff --git a/tuned.spec b/tuned.spec
+index 3a2dcec..1b46daf 100644
+--- a/tuned.spec
++++ b/tuned.spec
+@@ -334,8 +334,6 @@ fi
+ %changelog
+ * Tue Jul 19 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7.0-1
+ - new-release
+- - rebase tuned to latest upstream
+- resolves: rhbz#1289048
+ - gui: fixed save profile
+ resolves: rhbz#1242491
+ - tuned-adm: added --ignore-missing parameter
+diff --git a/tuned/admin/admin.py b/tuned/admin/admin.py
+index ad501c0..cbdd1be 100644
+--- a/tuned/admin/admin.py
++++ b/tuned/admin/admin.py
+@@ -98,7 +98,7 @@ class Admin(object):
+
+ def _action_list(self):
+ self._print_profiles(self._profiles_locator.get_known_names_summary())
+- self._action_dbus_active()
++ self._action_active()
+ return True
+
+ def _dbus_get_active_profile(self):
diff --git a/sys-apps/tuned/tuned-2.7.0.ebuild b/sys-apps/tuned/tuned-2.7.0.ebuild
new file mode 100644
index 000000000000..33e00738fd12
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://fedorahosted.org/tuned/"
+SRC_URI="https://fedorahosted.org/releases/t/u/tuned/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ sys-power/powertop
+ dev-util/systemtap
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-upstream.patch
+
+ sed -i \
+ -e "/^UNITDIR = /s:\$(shell rpm --eval '%{_unitdir}'):$(systemd_get_unitdir):" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ Makefile ||die
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/tuned.initd tuned
+
+ python_fix_shebang "${ED}"
+}