summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-06-13 16:35:56 +0200
committerSebastian Pipping <sping@gentoo.org>2020-06-13 16:36:54 +0200
commite5654371031677ef137a216f660fac55ddfd1df4 (patch)
treeaf67e0f0ba021a7278f035caeffab0044f850cb8 /sys-apps/usbguard
parentgames-engines/dMagnetic: Bump to 0.23, drop old 0.22 (diff)
downloadgentoo-e5654371031677ef137a216f660fac55ddfd1df4.tar.gz
gentoo-e5654371031677ef137a216f660fac55ddfd1df4.tar.bz2
gentoo-e5654371031677ef137a216f660fac55ddfd1df4.zip
sys-apps/usbguard: 0.7.8 + honor USE=-static-libs
Closes: https://bugs.gentoo.org/728088 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'sys-apps/usbguard')
-rw-r--r--sys-apps/usbguard/Manifest1
-rw-r--r--sys-apps/usbguard/usbguard-0.7.8.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-apps/usbguard/Manifest b/sys-apps/usbguard/Manifest
index 4929554c1e13..a4c0fa793139 100644
--- a/sys-apps/usbguard/Manifest
+++ b/sys-apps/usbguard/Manifest
@@ -1 +1,2 @@
DIST usbguard-0.7.6.tar.gz 1189194 BLAKE2B 4fefd9ccf13b094f64942559f481144f08986dc71154b87c1623459d2429c07e2738a17877d3f6c275e83ce904067b1284c588c9a95023c7205cc5e21ca118f0 SHA512 0b0d42276e48baac2dc1f9031eec25e3f622a8d6178cb0400b97c7d32005bfa158b60fd286fdc66206a8684658fefaf6389ef93511e942f025e75671d7455628
+DIST usbguard-0.7.8.tar.gz 1220764 BLAKE2B 8127acc0ef5dd89cc540097a71f10d56f3cb0a166453e27161e444d37dbf51cc4861bc9c71dcca16e9fec7187b3dcabb2bf08af522b2aaa4693fa4f4913a9ae0 SHA512 315c25ed7eb61cc0920047836dcca035cb07aecb6dfece9e4f6dc2ad61aaf6fdbf86898e43493958f3d12a146eb4c8f88b90bb246da0df83bb2097ce5b853e88
diff --git a/sys-apps/usbguard/usbguard-0.7.8.ebuild b/sys-apps/usbguard/usbguard-0.7.8.ebuild
new file mode 100644
index 000000000000..317ca17a882b
--- /dev/null
+++ b/sys-apps/usbguard/usbguard-0.7.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Daemon protecting your computer against BadUSB"
+HOMEPAGE="https://github.com/USBGuard/usbguard"
+SRC_URI="https://github.com/USBGuard/usbguard/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion dbus ldap policykit static-libs systemd"
+
+REQUIRED_USE="policykit? ( dbus )"
+
+CDEPEND="
+ dev-libs/pegtl
+ >=dev-libs/libsodium-0.4.5:=
+ >=dev-libs/protobuf-2.5.0:=
+ >=sys-cluster/libqb-0.16.0:=
+ sys-devel/gcc:*[cxx]
+ >=sys-libs/libcap-ng-0.7.0
+ >=sys-libs/libseccomp-2.0.0
+ >=sys-process/audit-2.7.7
+ bash-completion? ( >=app-shells/bash-completion-2.0 )
+ dbus? (
+ dev-libs/glib:2
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit[introspection] )
+ )
+ ldap? ( net-nds/openldap )
+ systemd? ( sys-apps/systemd )
+ "
+RDEPEND="${CDEPEND}
+ virtual/udev
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ dev-cpp/catch:1
+ dbus? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ )
+ "
+
+src_configure() {
+ local myargs=(
+ $(use_with dbus)
+ $(use_with ldap)
+ $(use_with policykit polkit)
+ $(use_enable static-libs static)
+ $(use_enable systemd)
+ )
+
+ econf "${myargs[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/log/usbguard
+
+ newinitd "${FILESDIR}"/${PN}-0.7.6-usbguard.openrc usbguard
+ use dbus && newinitd "${FILESDIR}"/${PN}-0.7.6-usbguard-dbus.openrc usbguard-dbus
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn 'BEFORE STARTING USBGUARD please be sure to create/generate'
+ ewarn ' a rules file at /etc/usbguard/rules.conf'
+ ewarn ' so that you do not'
+ ewarn ' GET LOCKED OUT'
+ ewarn " of this system (\"$(hostname)\")."
+ ewarn
+ ewarn 'This command may be of help:'
+ ewarn ' sudo sh -c "usbguard generate-policy > /etc/usbguard/rules.conf"'
+ ewarn
+}