summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-16 08:17:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-16 08:17:03 +0200
commit336d92bbfee20a0031bd09677eaf9764ccedb0f6 (patch)
treee4fe7d709e5288d439f12c32fe35943bddc392af /sys-apps/usbutils/usbutils-010.ebuild
parentwww-apache/passenger: cleanup (diff)
downloadgentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.tar.gz
gentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.tar.bz2
gentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.zip
sys-apps/usbutils: Bump to version 010
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-apps/usbutils/usbutils-010.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-010.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/usbutils/usbutils-010.ebuild b/sys-apps/usbutils/usbutils-010.ebuild
new file mode 100644
index 000000000000..6f049d0533bf
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-010.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="virtual/libusb:1=
+ virtual/libudev:="
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hwids
+ python? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use python && python_fix_shebang lsusb.py.in
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datarootdir="${EPREFIX}/usr/share"
+ --datadir="${EPREFIX}/usr/share/misc"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+
+ use python || rm -f "${ED%/}"/usr/bin/lsusb.py
+}