summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-08 23:45:36 +0100
committerSam James <sam@gentoo.org>2021-08-08 23:45:43 +0100
commitb90be910ff90c7e6650b9f6e211303feff5791c4 (patch)
treec8e2b359b8d907c78990c0f08f5e5d89a9eae458 /sys-apps/usbutils
parentdev-perl/SQL-Translator: Version bump 1.62 (diff)
downloadgentoo-b90be910ff90c7e6650b9f6e211303feff5791c4.tar.gz
gentoo-b90be910ff90c7e6650b9f6e211303feff5791c4.tar.bz2
gentoo-b90be910ff90c7e6650b9f6e211303feff5791c4.zip
sys-apps/usbutils: disable py3.7, fix BDEPEND, missing die
- Drop Python 3.7 (it's a noop, support is gone from the eclass) - We need Python as a BDEPEND if USE=python too - Add missing die Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/usbutils-014.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-apps/usbutils/usbutils-014.ebuild b/sys-apps/usbutils/usbutils-014.ebuild
index c92094e848bd..14581fea76a9 100644
--- a/sys-apps/usbutils/usbutils-014.ebuild
+++ b/sys-apps/usbutils/usbutils-014.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit autotools python-single-r1
@@ -21,7 +21,8 @@ DEPEND="virtual/libusb:1=
virtual/libudev:="
BDEPEND="
app-arch/xz-utils
- virtual/pkgconfig"
+ virtual/pkgconfig
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}
sys-apps/hwids
python? ( ${PYTHON_DEPS} )"
@@ -49,5 +50,7 @@ src_install() {
newdoc usbhid-dump/NEWS NEWS.usbhid-dump
dobin usbreset # noinst_PROGRAMS, but installed by other distros
- use python || rm -f "${ED}"/usr/bin/lsusb.py
+ if ! use python ; then
+ rm -f "${ED}"/usr/bin/lsusb.py || die
+ fi
}