summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-12 11:24:33 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-12 11:24:33 +0100
commit37f9b7c2560e861f5148f96bf80ec97b287495bc (patch)
treeaccd6c5a4079d749be8ac70e66432994c6ef1542 /sys-apps/usermode-utilities
parentsys-fs/lessfs: Fix deps and homepage (diff)
downloadgentoo-37f9b7c2560e861f5148f96bf80ec97b287495bc.tar.gz
gentoo-37f9b7c2560e861f5148f96bf80ec97b287495bc.tar.bz2
gentoo-37f9b7c2560e861f5148f96bf80ec97b287495bc.zip
sys-apps/usermode-utilities: Use proper fuse slot
Closes: https://bugs.gentoo.org/673674 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-apps/usermode-utilities')
-rw-r--r--sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch8
-rw-r--r--sys-apps/usermode-utilities/usermode-utilities-20070815-r4.ebuild44
2 files changed, 48 insertions, 4 deletions
diff --git a/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch
index 13fd556ec98d..00531a1db2bf 100644
--- a/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch
+++ b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch
@@ -2,8 +2,8 @@ https://bugs.gentoo.org/580816
include headers needed by targets
---- b/tools-20070815/uml_net/ethertap.c
-+++ a/tools-20070815/uml_net/ethertap.c
+--- b/uml_net/ethertap.c
++++ a/uml_net/ethertap.c
@@ -13,6 +13,7 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
@@ -15,8 +15,8 @@ include headers needed by targets
for major/minor macros
---- b/tools-20070815/uml_net/host.c
-+++ a/tools-20070815/uml_net/host.c
+--- b/uml_net/host.c
++++ a/uml_net/host.c
@@ -10,6 +10,7 @@
#include <ctype.h>
#include <sys/wait.h>
diff --git a/sys-apps/usermode-utilities/usermode-utilities-20070815-r4.ebuild b/sys-apps/usermode-utilities/usermode-utilities-20070815-r4.ebuild
new file mode 100644
index 000000000000..04ceb9e3621c
--- /dev/null
+++ b/sys-apps/usermode-utilities/usermode-utilities-20070815-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tools for use with Usermode Linux virtual machines"
+HOMEPAGE="http://user-mode-linux.sourceforge.net/"
+SRC_URI="http://user-mode-linux.sourceforge.net/uml_utilities_${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="fuse"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0= )
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/tools-${PV}
+
+src_prepare() {
+ default
+
+ # Merge previous patches with fix for bug #331099
+ eapply "${FILESDIR}"/${P}-rollup.patch
+ # Fix owner of humfsify; bug #364531
+ eapply "${FILESDIR}"/${P}-humfsify-owner.patch
+ eapply "${FILESDIR}"/${P}-headers.patch #580816
+
+ sed -i -e 's:-o \$(BIN):$(LDFLAGS) -o $(BIN):' "${S}"/*/Makefile || die "LDFLAGS sed failed"
+ sed -i -e 's:-o \$@:$(LDFLAGS) -o $@:' "${S}"/moo/Makefile || die "LDFLAGS sed (moo) failed"
+ if ! use fuse; then
+ einfo "Skipping build of umlmount to avoid sys-fs/fuse dependency."
+ sed -i -e 's/\<umlfs\>//' Makefile || die "sed to remove sys-fs/fuse dependency failed"
+ fi
+}
+
+src_compile() {
+ tc-export AR CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS} -DTUNTAP -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -g -Wall" all
+}