summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-14 15:18:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-14 15:36:10 +0200
commitf917c3be712532a2d71a3ed79e0bac3e52162564 (patch)
tree0fa45cf6908ec4350aac3b98d5e85308958678ca /sys-apps/util-linux
parentsys-apps/util-linux: Removed old. (diff)
downloadgentoo-f917c3be712532a2d71a3ed79e0bac3e52162564.tar.gz
gentoo-f917c3be712532a2d71a3ed79e0bac3e52162564.tar.bz2
gentoo-f917c3be712532a2d71a3ed79e0bac3e52162564.zip
sys-apps/util-linux: Synced live ebuild.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index c86046927fcf..c8d83a120f7f 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 \
- python-single-r1 multilib-minimal systemd
+inherit ltprune toolchain-funcs libtool flag-o-matic bash-completion-r1 \
+ pam python-single-r1 multilib-minimal systemd
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
if [[ ${PV} == 9999 ]] ; then
- inherit git-2 autotools
+ inherit git-r3 autotools
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
else
[[ "${PV}" = *_rc* ]] || \
@@ -66,13 +66,18 @@ pkg_setup() {
}
src_prepare() {
+ default
+
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
fi
+ # Undo bad ncurses handling by upstream. #601530
+ sed -i -E \
+ -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
+ -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
+ configure || die
elibtoolize
-
- epatch_user
}
lfs_fallocate_test() {
@@ -113,7 +118,7 @@ multilib_src_configure() {
--enable-rename
--enable-schedutils
--with-bashcompletiondir="$(get_bashcompdir)"
- --with-systemdsystemunitdir=$(multilib_native_usex systemd "$(systemd_get_unitdir)" "no")
+ --with-systemdsystemunitdir=$(multilib_native_usex systemd "$(systemd_get_systemunitdir)" "no")
$(multilib_native_use_enable caps setpriv)
$(multilib_native_use_enable cramfs)
$(multilib_native_use_enable fdformat)
@@ -137,8 +142,7 @@ multilib_src_configure() {
$(use_with selinux)
$(usex ncurses '' '--without-tinfo')
)
- ECONF_SOURCE=${S} \
- econf "${myeconfargs[@]}"
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
@@ -178,6 +182,11 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
prune_libtool_files
+
+ if use pam; then
+ newpamd "${FILESDIR}/runuser.pamd" runuser
+ newpamd "${FILESDIR}/runuser-l.pamd" runuser-l
+ fi
}
pkg_postinst() {