summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 15:58:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-28 16:43:18 -0400
commit948dbb676ad148f1b0288d8a95de6f8c19dd486c (patch)
treeba40a1f34fd7c2682b8e2475781033fbbecc7465 /sys-apps/vbetool
parentsci-calculators/hcalc: fix build with clang16 (diff)
downloadgentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.tar.gz
gentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.tar.bz2
gentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.zip
sys-apps/vbetool: add 1.2.2
This fork is ~13 years old but it fixes our clang16 issues and several distros are using it, let's take it (albeit unsure how useful this package still is, don't use myself). dev.g.o tarball is a checkout of upstream v1.2.2 tag with no changes. Closes: https://bugs.gentoo.org/787245 Closes: https://bugs.gentoo.org/870523 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/Manifest1
-rw-r--r--sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch7
-rw-r--r--sys-apps/vbetool/vbetool-1.2.2.ebuild31
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/vbetool/Manifest b/sys-apps/vbetool/Manifest
index 4a22534a6505..8f8fce89d84c 100644
--- a/sys-apps/vbetool/Manifest
+++ b/sys-apps/vbetool/Manifest
@@ -1 +1,2 @@
DIST vbetool-1.1.tar.gz 182826 BLAKE2B 6b30eb468e55bedd766161e373e042b5fdf38fd2926bfc8aeb94404350864e835d41642f19be155fcf9a8fbfdc8b4e237e742cabd00626db5e8d17e7c7c5cf6f SHA512 09d8713516f074fe8e901ab3e24aba7e8b9ddf459b3ee3394b7604e4489a70a27c6dc3604cf1284c49233dba908f00da746c583562af2bc93b6df8ff413efd96
+DIST vbetool-1.2.2.tar.xz 22032 BLAKE2B 0ab3263d347ad382c73265e08bb2d81468e1066212a282eee972f1e806a8cef94a0194878a8f2a113d3c139a58b9b18a8e3e6153ce868803bd74c3724e61d9d2 SHA512 658028e6fd1e1218c08a55de75009b6256f46dd22e259a5ab605d4686baf909688997882ba98ee7bee9b26b0dd334a38ddd7e63d8884626f8c3e0cedf87c4dea
diff --git a/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch b/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch
new file mode 100644
index 000000000000..f3f4c36d0219
--- /dev/null
+++ b/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch
@@ -0,0 +1,7 @@
+Gentoo's libx86 package does not have a .pc file (adds -lx86 either way).
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,3 +38,2 @@
+ # Checks for pkg-config packages
+-PKG_CHECK_MODULES(LIBX86, x86)
+
diff --git a/sys-apps/vbetool/vbetool-1.2.2.ebuild b/sys-apps/vbetool/vbetool-1.2.2.ebuild
new file mode 100644
index 000000000000..9ad425b7bd53
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hw state (i.e. reinitialize video card)"
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/vbetool/"
+SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libx86
+ sys-libs/zlib:=
+ x11-libs/libpciaccess"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libx86.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}