summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/which
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/which')
-rw-r--r--sys-apps/which/Manifest2
-rw-r--r--sys-apps/which/metadata.xml5
-rw-r--r--sys-apps/which/which-2.20-r1.ebuild25
-rw-r--r--sys-apps/which/which-2.21.ebuild25
4 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/which/Manifest b/sys-apps/which/Manifest
new file mode 100644
index 000000000000..4ff718fec18e
--- /dev/null
+++ b/sys-apps/which/Manifest
@@ -0,0 +1,2 @@
+DIST which-2.20.tar.gz 135372 SHA256 d417b65c650d88ad26a208293c1c6e3eb60d4b6d847f01ff8f66aca63e2857f8 SHA512 29445cd6072814d3a6179b53b8f9e7e3fc8a27b77315f2a04171e177397b91ff80a97db8806fc6b1f08dab8cbca6f208d9d7845858268b121b3af396a4a9062e WHIRLPOOL 35ca3dfc47e6112a2827188b979bc19d369f69f5841dca445039036e6fa5423b0e4e9efddd370f92da16a3873523bf37f7bdf68b748fc78e5b7991290875c49d
+DIST which-2.21.tar.gz 149305 SHA256 f4a245b94124b377d8b49646bf421f9155d36aa7614b6ebf83705d3ffc76eaad SHA512 d2f04a5c5291f2d7d1226982da7cf999d36cfe24d3f7bda145508efcfb359511251d3c68b860c0ddcedd66b15a0587b648a35ab6d1f173707565305c506dfc61 WHIRLPOOL e1712d2f2b48467300f5947d0a72c0cf759bc33001661ba41cd57cefe21cb9974cc318748d76ff73c71fb869c4d7a445973ad95777ab380f673c85095360fd57
diff --git a/sys-apps/which/metadata.xml b/sys-apps/which/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/which/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-apps/which/which-2.20-r1.ebuild b/sys-apps/which/which-2.20-r1.ebuild
new file mode 100644
index 000000000000..640bfed058a2
--- /dev/null
+++ b/sys-apps/which/which-2.20-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Prints out location of specified executables that are in your path"
+HOMEPAGE="https://carlowood.github.io/which/"
+SRC_URI="https://carlowood.github.io/which/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ append-lfs-flags
+}
+
+src_configure() {
+ tc-export AR
+ default
+}
diff --git a/sys-apps/which/which-2.21.ebuild b/sys-apps/which/which-2.21.ebuild
new file mode 100644
index 000000000000..6eabd01a7a59
--- /dev/null
+++ b/sys-apps/which/which-2.21.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Prints out location of specified executables that are in your path"
+HOMEPAGE="https://carlowood.github.io/which/"
+SRC_URI="https://carlowood.github.io/which/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ append-lfs-flags
+}
+
+src_configure() {
+ tc-export AR
+ default
+}