summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-27 14:13:45 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-03-28 12:58:00 -0500
commit90facfab5ee0c03b921351379fc31bd2493a5700 (patch)
treeb964a04ba1f65511d825bf91ef815aa20e38a2e9 /sys-apps/yarn/yarn-1.5.1.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.15.14 (diff)
downloadgentoo-90facfab5ee0c03b921351379fc31bd2493a5700.tar.gz
gentoo-90facfab5ee0c03b921351379fc31bd2493a5700.tar.bz2
gentoo-90facfab5ee0c03b921351379fc31bd2493a5700.zip
sys-apps/yarn: 1.5.1 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/yarn/yarn-1.5.1.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/yarn/yarn-1.5.1.ebuild b/sys-apps/yarn/yarn-1.5.1.ebuild
new file mode 100644
index 000000000000..bb76e804940f
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/yarn-v${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+ fperms a+x "${install_dir}/bin/yarn.js"
+ while read -r -d '' path; do
+ [[ $(head -n1 "${path}") == \#\!* ]] || continue
+ chmod +x "${path}" || die #614094
+ done < <(find "${ED}" -type f -print0)
+}