summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-03-07 22:43:33 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2017-03-07 16:11:35 -0500
commit0c0ad370b30b9f5b31bf6f0bb62f48d8034cfb7b (patch)
treeb8cff23a9279c80669773d40bf1c04bc354cb6d4 /sys-apps
parentsys-apps/yarn: version bump to 0.21.3 (diff)
downloadgentoo-0c0ad370b30b9f5b31bf6f0bb62f48d8034cfb7b.tar.gz
gentoo-0c0ad370b30b9f5b31bf6f0bb62f48d8034cfb7b.tar.bz2
gentoo-0c0ad370b30b9f5b31bf6f0bb62f48d8034cfb7b.zip
sys-apps/yarn: delete non-working 9999 version
npm install' or 'yarn install' is not suitable for ebuild
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/yarn/yarn-9999.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/sys-apps/yarn/yarn-9999.ebuild b/sys-apps/yarn/yarn-9999.ebuild
deleted file mode 100644
index 4d0ba07bee9e..000000000000
--- a/sys-apps/yarn/yarn-9999.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit git-r3
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-EGIT_REPO_URI="https://github.com/yarnpkg/yarn.git"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn"
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- fperms a+x "${install_dir}/bin/yarn.js"
-}